Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1477753

[RFC PATCH 0/4] futex: Introducing throughput-optimized futexes

From Waiman Long <Waiman.Long@hpe.com>
Newsgroups linux.kernel
Subject [RFC PATCH 0/4] futex: Introducing throughput-optimized futexes
Date 2016-09-06 21:00 +0200
Message-ID <setLb-5Jg-13@gated-at.bofh.it> (permalink)
Organization linux.* mail to news gateway

Show all headers | View raw


This patchset introduces a new futex implementation called
throughput-optimized (TO) futexes. It is similar to PI futexes in its
calling convention, but provides better throughput than the wait-wake
futexes by encouraging lock stealing and optimistic spinning.

The timeout parameter, however, isn't quite working yet. More
investigation will have to be done to see if this can be fixed or
the timeout parameter has to be scrapped entirely.

Waiman Long (4):
  futex: Add futex_set_timer() helper function
  futex: Rename futex_pi_state to futex_state
  futex: Throughput-optimized (TO) futexes
  futex, doc: TO futexes document

 Documentation/00-INDEX     |    2 +
 Documentation/to-futex.txt |  124 ++++++++
 include/linux/sched.h      |    4 +-
 include/uapi/linux/futex.h |    4 +
 kernel/futex.c             |  675 ++++++++++++++++++++++++++++++++++++++------
 5 files changed, 719 insertions(+), 90 deletions(-)
 create mode 100644 Documentation/to-futex.txt

Back to linux.kernel | Previous | NextNext in thread | Find similar | Unroll thread


Thread

[RFC PATCH 0/4] futex: Introducing throughput-optimized futexes Waiman Long <Waiman.Long@hpe.com> - 2016-09-06 21:00 +0200
  [RFC PATCH 1/4] futex: Add futex_set_timer() helper function Waiman Long <Waiman.Long@hpe.com> - 2016-09-06 21:00 +0200
  [RFC PATCH 2/4] futex: Rename futex_pi_state to futex_state Waiman Long <Waiman.Long@hpe.com> - 2016-09-06 21:00 +0200
  [RFC PATCH 3/4] futex: Throughput-optimized (TO) futexes Waiman Long <Waiman.Long@hpe.com> - 2016-09-06 21:00 +0200

csiph-web