Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1478654
| From | Linus Walleij <linus.walleij@linaro.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 2/5] gpio: pca953x: code shrink |
| Date | 2016-09-08 00:10 +0200 |
| Message-ID | <seTcB-5MW-3@gated-at.bofh.it> (permalink) |
| References | <se3e1-50e-1@gated-at.bofh.it> <se3e3-50e-51@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Mon, Sep 5, 2016 at 4:31 PM, Bartosz Golaszewski <bgolaszewski@baylibre.com> wrote: > There are multiple places in the driver code where a > switch (chip->chip_type) is used to determine the proper register > offset. > > Unduplicate the code by adding a simple structure holding the possible > offsets that differ between the pca953x and pca957x chip families and > use it to avoid the checks. > > Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com> This doesn't apply beacuse of other changes made to the driver by Phil Reid et al. Can you please rebase your work on top of my gpio "devel" branch: https://git.kernel.org/cgit/linux/kernel/git/linusw/linux-gpio.git/log/?h=devel and at the same time fix Geert's reported const thing? I'm overall happy with the patch series and would like to apply also patches 2-5 for v4.9 soon. Yours, Linus Walleij
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 0/5] gpio: pca953x: code refactoring Bartosz Golaszewski <bgolaszewski@baylibre.com> - 2016-09-05 16:40 +0200
[PATCH 4/5] gpio: pca953x: remove an unused variable Bartosz Golaszewski <bgolaszewski@baylibre.com> - 2016-09-05 16:40 +0200
[PATCH 5/5] gpio: pca953x: refactor pca953x_read_regs() Bartosz Golaszewski <bgolaszewski@baylibre.com> - 2016-09-05 16:40 +0200
[PATCH 1/5] gpio: pca953x: coding style fixes Bartosz Golaszewski <bgolaszewski@baylibre.com> - 2016-09-05 16:40 +0200
Re: [PATCH 1/5] gpio: pca953x: coding style fixes Linus Walleij <linus.walleij@linaro.org> - 2016-09-08 00:00 +0200
Re: [PATCH 1/5] gpio: pca953x: coding style fixes Linus Walleij <linus.walleij@linaro.org> - 2016-09-08 01:20 +0200
[PATCH 3/5] gpio: pca953x: refactor pca953x_write_regs() Bartosz Golaszewski <bgolaszewski@baylibre.com> - 2016-09-05 16:40 +0200
[PATCH 2/5] gpio: pca953x: code shrink Bartosz Golaszewski <bgolaszewski@baylibre.com> - 2016-09-05 16:40 +0200
Re: [PATCH 2/5] gpio: pca953x: code shrink Geert Uytterhoeven <geert@linux-m68k.org> - 2016-09-05 16:50 +0200
Re: [PATCH 2/5] gpio: pca953x: code shrink Linus Walleij <linus.walleij@linaro.org> - 2016-09-08 00:10 +0200
Re: [PATCH 0/5] gpio: pca953x: code refactoring Linus Walleij <linus.walleij@linaro.org> - 2016-09-08 00:10 +0200
csiph-web