Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1478394

Re: [PATCH v4 5/5] gpio: pca953x: coding style fixes

From Bartosz Golaszewski <bgolaszewski@baylibre.com>
Newsgroups linux.kernel
Subject Re: [PATCH v4 5/5] gpio: pca953x: coding style fixes
Date 2016-09-07 17:20 +0200
Message-ID <seMNP-1pB-5@gated-at.bofh.it> (permalink)
References <seMkN-109-5@gated-at.bofh.it> <seMuv-13P-67@gated-at.bofh.it> <seMNP-1pB-7@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


2016-09-07 17:17 GMT+02:00 Andy Shevchenko <andriy.shevchenko@linux.intel.com>:
> On Wed, 2016-09-07 at 16:49 +0200, Bartosz Golaszewski wrote:
>> pca953x_gpio_set_multiple() has some coding style issues that make it
>> harder to read. Tweak the code a bit.
>>
>
> Usually give one day for reviewers to have a chance to follow your
> changes.
>

Sure, I re-posted immediately because the changes were minor.

Thanks,
Bartosz

> And one comment below.
>
>> Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com>
>> Reviewed-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
>> ---
>>  drivers/gpio/gpio-pca953x.c | 22 ++++++++++++----------
>>  1 file changed, 12 insertions(+), 10 deletions(-)
>>
>> diff --git a/drivers/gpio/gpio-pca953x.c b/drivers/gpio/gpio-pca953x.c
>> index b08ed52..079c311 100644
>> --- a/drivers/gpio/gpio-pca953x.c
>> +++ b/drivers/gpio/gpio-pca953x.c
>> @@ -360,25 +360,27 @@ exit:
>>  }
>>
>>  static void pca953x_gpio_set_multiple(struct gpio_chip *gc,
>> -             unsigned long *mask, unsigned long *bits)
>> +                                   unsigned long *mask, unsigned
>> long *bits)
>>  {
>>       struct pca953x_chip *chip = gpiochip_get_data(gc);
>> +     unsigned int bankmask, bankval;
>> +     int bank_shift, bank, ret;
>>       u8 reg_val[MAX_BANK];
>> -     int ret;
>> -     int bank_shift = fls((chip->gpio_chip.ngpio - 1) / BANK_SZ);
>> -     int bank;
>
> I meant to keep int ret apart.
>
> struct pca953x_chip *chip = gpiochip_get_data(gc);
> unsigned int bank_mask, bank_val, bank_shift, bank;
> u8 reg_val[MAX_BANK];
> int ret;
>
> And perhaps _ in the names of bank* to be consistent.
>
>
> --
> Andy Shevchenko <andriy.shevchenko@linux.intel.com>
> Intel Finland Oy
> --
> To unsubscribe from this list: send the line "unsubscribe linux-gpio" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v4 0/5] gpio: pca953x: code refactoring Bartosz Golaszewski <bgolaszewski@baylibre.com> - 2016-09-07 16:50 +0200
  [PATCH v4 3/5] gpio: pca953x: refactor pca953x_read_regs() Bartosz Golaszewski <bgolaszewski@baylibre.com> - 2016-09-07 17:00 +0200
  [PATCH v4 4/5] gpio: pca953x: remove an unused variable Bartosz Golaszewski <bgolaszewski@baylibre.com> - 2016-09-07 17:00 +0200
  [PATCH v4 2/5] gpio: pca953x: refactor pca953x_write_regs() Bartosz Golaszewski <bgolaszewski@baylibre.com> - 2016-09-07 17:00 +0200
  [PATCH v4 1/5] gpio: pca953x: code shrink Bartosz Golaszewski <bgolaszewski@baylibre.com> - 2016-09-07 17:00 +0200
    Re: [PATCH v4 1/5] gpio: pca953x: code shrink Joe Perches <joe@perches.com> - 2016-09-07 17:10 +0200
  [PATCH v4 5/5] gpio: pca953x: coding style fixes Bartosz Golaszewski <bgolaszewski@baylibre.com> - 2016-09-07 17:00 +0200
    Re: [PATCH v4 5/5] gpio: pca953x: coding style fixes Bartosz Golaszewski <bgolaszewski@baylibre.com> - 2016-09-07 17:20 +0200
    Re: [PATCH v4 5/5] gpio: pca953x: coding style fixes Andy Shevchenko <andriy.shevchenko@linux.intel.com> - 2016-09-07 17:20 +0200

csiph-web