Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1476885

Re: [PATCH v4 3/3] iio: adc: add support for Allwinner SoCs ADC

From Joshua Clayton <stillcompiling@gmail.com>
Newsgroups linux.kernel
Subject Re: [PATCH v4 3/3] iio: adc: add support for Allwinner SoCs ADC
Date 2016-09-05 19:50 +0200
Message-ID <se6bV-6U4-77@gated-at.bofh.it> (permalink)
References <scAQN-2Sv-3@gated-at.bofh.it> <sdWcx-t1-5@gated-at.bofh.it> <sdWmd-xw-1@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Monday, September 05, 2016 09:11:47 AM Quentin Schulz wrote:
> On 05/09/2016 09:07, Maxime Ripard wrote:
> > Hi,
> > 
> > Nitpicks ahead.
> > 
> > On Thu, Sep 01, 2016 at 04:05:05PM +0200, Quentin Schulz wrote:
> >> +	info->soc_specific = (struct soc_specific *)platform_get_device_id(pdev)->driver_data;
> > 
> > This line is still rather long. How about calling the field "data" and
> > the structure gpadc_data?
> > 
> 
> driver_data is coming from the platform_device_id
> (http://lxr.free-electrons.com/source/include/linux/mod_devicetable.h#L498)
> so can't really change that.
> I could change the structure to gpadc_data, that would save me 2
> characters, still 13 characters above the 80 characters limit however.
> 
I think Maxime meant to change member "soc_specific" to "data" of type
struct gpadc_data

> >> +
> >> +	tzd = devm_thermal_zone_of_sensor_register(pdev->dev.parent, 0, info,
> >> +						   &sun4i_ts_tz_ops);
> > 
> > A comment on why you put the parent device structure and not the
> > device itself like you're doing on all the other calls in that probe
> > would be nice.
> > 
> 
> Indeed.
> 
> Thanks,
> Quentin
> 
> > Thanks!
> > Maxime
> > 
> 

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v4 0/3] add support for Allwinner SoCs ADC Quentin Schulz <quentin.schulz@free-electrons.com> - 2016-09-01 16:10 +0200
  [PATCH v4 3/3] iio: adc: add support for Allwinner SoCs ADC Quentin Schulz <quentin.schulz@free-electrons.com> - 2016-09-01 16:10 +0200
    Re: [PATCH v4 3/3] iio: adc: add support for Allwinner SoCs ADC Jonathan Cameron <jic23@kernel.org> - 2016-09-04 16:40 +0200
      Re: [PATCH v4 3/3] iio: adc: add support for Allwinner SoCs ADC Quentin Schulz <quentin.schulz@free-electrons.com> - 2016-09-05 08:30 +0200
        Re: [PATCH v4 3/3] iio: adc: add support for Allwinner SoCs ADC Jonathan Cameron <jic23@kernel.org> - 2016-09-05 22:00 +0200
    Re: [PATCH v4 3/3] iio: adc: add support for Allwinner SoCs ADC Peter Meerwald-Stadler <pmeerw@pmeerw.net> - 2016-09-04 18:20 +0200
      Re: [PATCH v4 3/3] iio: adc: add support for Allwinner SoCs ADC Quentin Schulz <quentin.schulz@free-electrons.com> - 2016-09-05 08:50 +0200
        Re: [PATCH v4 3/3] iio: adc: add support for Allwinner SoCs ADC Peter Meerwald-Stadler <pmeerw@pmeerw.net> - 2016-09-05 10:10 +0200
          Re: [PATCH v4 3/3] iio: adc: add support for Allwinner SoCs ADC Quentin Schulz <quentin.schulz@free-electrons.com> - 2016-09-05 11:00 +0200
            Re: [PATCH v4 3/3] iio: adc: add support for Allwinner SoCs ADC Peter Meerwald-Stadler <pmeerw@pmeerw.net> - 2016-09-05 11:10 +0200
    Re: [PATCH v4 3/3] iio: adc: add support for Allwinner SoCs ADC Maxime Ripard <maxime.ripard@free-electrons.com> - 2016-09-05 09:10 +0200
      Re: [PATCH v4 3/3] iio: adc: add support for Allwinner SoCs ADC Quentin Schulz <quentin.schulz@free-electrons.com> - 2016-09-05 09:20 +0200
        Re: [PATCH v4 3/3] iio: adc: add support for Allwinner SoCs ADC Joshua Clayton <stillcompiling@gmail.com> - 2016-09-05 19:50 +0200
  [PATCH v4 1/3] hwmon: iio_hwmon: delay probing with late_initcall Quentin Schulz <quentin.schulz@free-electrons.com> - 2016-09-01 16:10 +0200

csiph-web