Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1474622
| From | Joe Perches <joe@perches.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] staging: android: lowmemorykiller.c: Fix checkpatch warning |
| Date | 2016-09-01 23:20 +0200 |
| Message-ID | <scHyW-75a-21@gated-at.bofh.it> (permalink) |
| References | <sa4BI-2Is-21@gated-at.bofh.it> <sa4Lo-2LX-27@gated-at.bofh.it> <scCfT-3EJ-13@gated-at.bofh.it> <scHpg-70l-63@gated-at.bofh.it> <scHpg-70l-61@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Thu, 2016-09-01 at 20:33 +0200, Greg Kroah-Hartman wrote: > On Thu, Sep 01, 2016 at 11:19:41AM -0700, Joe Perches wrote: > > On Thu, 2016-09-01 at 17:36 +0200, Greg Kroah-Hartman wrote: > > > On Thu, Aug 25, 2016 at 06:26:48PM +0300, Andrey Utkin wrote: > > > > On Thu, Aug 25, 2016 at 11:10:25AM -0400, Anson Jacob wrote: > > > > > Fix checkpatch.pl 'line over 80 characters' warning [] > > > > > diff --git a/drivers/staging/android/lowmemorykiller.c b/drivers/staging/android/lowmemorykiller.c [] > > > > > @@ -92,8 +92,8 @@ static unsigned long lowmem_scan(struct shrinker *s, struct shrink_control *sc) > > > > > int array_size = ARRAY_SIZE(lowmem_adj); > > > > > int other_free = global_page_state(NR_FREE_PAGES) - totalreserve_pages; > > > > > int other_file = global_node_page_state(NR_FILE_PAGES) - > > > > > - global_node_page_state(NR_SHMEM) - > > > > > - total_swapcache_pages(); > > > > > + global_node_page_state(NR_SHMEM) - > > > > > + total_swapcache_pages(); > > > > > > > > > > if (lowmem_adj_size < array_size) > > > > > array_size = lowmem_adj_size; > > > > Indeed original alignment on opening brace here doesn't make sense. > > > > I don't mind if your patch gets accepted, but out of curiosity I have opened > > > > this file in vim with kernel coding style plugin loaded > > > > (https://github.com/vivien/vim-linux-coding-style), selected the affected > > > > lines, and reindented the selection by pressing 'gq'. It ended up with this, > > > > being both shorter and simpler: > > > > > > > > diff --git a/drivers/staging/android/lowmemorykiller.c b/drivers/staging/android/lowmemorykiller.c [] > > > > @@ -92,8 +92,7 @@ static unsigned long lowmem_scan(struct shrinker *s, struct shrink_control *sc) > > > > int array_size = ARRAY_SIZE(lowmem_adj); > > > > int other_free = global_page_state(NR_FREE_PAGES) - totalreserve_pages; > > > > int other_file = global_node_page_state(NR_FILE_PAGES) - > > > > - global_node_page_state(NR_SHMEM) - > > > > - total_swapcache_pages(); > > > > + global_node_page_state(NR_SHMEM) - total_swapcache_pages(); > > > The original patch here is nicer to read, don't you think? > > Strictly, these should probably be unsigned long instead of int > > as that's the return type of global_[node_]page_state(). > > > > Maybe something like the below, but then maybe other_free/file > > should become unsigned long too. [] > > diff --git a/drivers/staging/android/lowmemorykiller.c b/drivers/staging/android/lowmemorykiller.c [] > > @@ -90,10 +90,11 @@ static unsigned long lowmem_scan(struct shrinker *s, struct shrink_control *sc) > > int selected_tasksize = 0; > > short selected_oom_score_adj; > > int array_size = ARRAY_SIZE(lowmem_adj); > > - int other_free = global_page_state(NR_FREE_PAGES) - totalreserve_pages; > > - int other_file = global_node_page_state(NR_FILE_PAGES) - > > - global_node_page_state(NR_SHMEM) - > > - total_swapcache_pages(); > > + unsigned long nr_free = global_page_state(NR_FREE_PAGES); > > + unsigned long nr_file = global_node_page_state(NR_FILE_PAGES); > > + unsigned long nr_shmem = global_node_page_state(NR_SHMEM); > > + int other_free = nr_free - totalreserve_pages; > > + int other_file = nr_file - nr_shmem - total_swapcache_pages(); > > > > if (lowmem_adj_size < array_size) > > array_size = lowmem_adj_size; > I like it, much easier to follow. Care to resend it in a patch form I > can apply it in? I think the android folk should figure out what the right thing to do with the int/unsigned long calculation is first. Arve? Riley?
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH] staging: android: lowmemorykiller.c: Fix checkpatch warning Anson Jacob <ansonjacob.aj@gmail.com> - 2016-08-25 17:20 +0200
Re: [PATCH] staging: android: lowmemorykiller.c: Fix checkpatch warning Andrey Utkin <andrey_utkin@fastmail.com> - 2016-08-25 17:30 +0200
Re: [PATCH] staging: android: lowmemorykiller.c: Fix checkpatch warning Greg Kroah-Hartman <gregkh@linuxfoundation.org> - 2016-09-01 17:40 +0200
Re: [PATCH] staging: android: lowmemorykiller.c: Fix checkpatch warning Greg Kroah-Hartman <gregkh@linuxfoundation.org> - 2016-09-01 23:10 +0200
Re: [PATCH] staging: android: lowmemorykiller.c: Fix checkpatch warning Arve Hjønnevåg <arve@android.com> - 2016-09-01 23:20 +0200
Re: [PATCH] staging: android: lowmemorykiller.c: Fix checkpatch warning Joe Perches <joe@perches.com> - 2016-09-01 23:20 +0200
Re: [PATCH] staging: android: lowmemorykiller.c: Fix checkpatch warning Joe Perches <joe@perches.com> - 2016-09-02 00:00 +0200
csiph-web