Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1556308

Re: [PATCH v2 7/8] net: Rename TCA*BPF_DIGEST to ..._SHA256

From Daniel Borkmann <daniel@iogearbox.net>
Newsgroups linux.kernel
Subject Re: [PATCH v2 7/8] net: Rename TCA*BPF_DIGEST to ..._SHA256
Date 2017-01-11 10:20 +0100
Message-ID <sYnex-565-7@gated-at.bofh.it> (permalink)
References <sYe1z-7Gf-11@gated-at.bofh.it> <sYe1z-7Gf-13@gated-at.bofh.it> <sYfqG-8og-13@gated-at.bofh.it> <sYhC9-1wa-1@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Hi Andy,

On 01/11/2017 04:11 AM, Andy Lutomirski wrote:
> On Tue, Jan 10, 2017 at 4:50 PM, Daniel Borkmann <daniel@iogearbox.net> wrote:
>> On 01/11/2017 12:24 AM, Andy Lutomirski wrote:
>>>
>>> This makes it easier to add another digest algorithm down the road if
>>> needed.  It also serves to force any programs that might have been
>>> written against a kernel that had the old field name to notice the
>>> change and make any necessary changes.
>>>
>>> This shouldn't violate any stable API policies, as no released kernel
>>> has ever had TCA*BPF_DIGEST.
>>
>> Imho, this and patch 6/8 is not really needed. Should there ever
>> another digest alg be used (doubt it), then you'd need a new nl
>> attribute and fdinfo line anyway to keep existing stuff intact.
>> Nobody made the claim that you can just change this underneath
>> and not respecting abi for existing applications when I read from
>> above that such apps now will get "forced" to notice a change.
>
> Fair enough.  I was more concerned about prerelease iproute2 versions,
> but maybe that's a nonissue.  I'll drop these two patches.

Ok. Sleeping over this a bit, how about a general rename into
"prog_tag" for fdinfo and TCA_BPF_TAG resp. TCA_ACT_BPF_TAG for
the netlink attributes, fwiw, it might reduce any assumptions on
this being made? If this would be preferable, I could cook that
patch against -net for renaming it?

Thanks,
Daniel

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v2 7/8] net: Rename TCA*BPF_DIGEST to ..._SHA256 Andy Lutomirski <luto@kernel.org> - 2017-01-11 00:30 +0100
  Re: [PATCH v2 7/8] net: Rename TCA*BPF_DIGEST to ..._SHA256 Daniel Borkmann <daniel@iogearbox.net> - 2017-01-11 02:00 +0100
    Re: [PATCH v2 7/8] net: Rename TCA*BPF_DIGEST to ..._SHA256 Andy Lutomirski <luto@amacapital.net> - 2017-01-11 04:20 +0100
      Re: [PATCH v2 7/8] net: Rename TCA*BPF_DIGEST to ..._SHA256 Daniel Borkmann <daniel@iogearbox.net> - 2017-01-11 10:20 +0100
        Re: [PATCH v2 7/8] net: Rename TCA*BPF_DIGEST to ..._SHA256 Andy Lutomirski <luto@amacapital.net> - 2017-01-11 19:30 +0100
          Re: [PATCH v2 7/8] net: Rename TCA*BPF_DIGEST to ..._SHA256 Daniel Borkmann <daniel@iogearbox.net> - 2017-01-14 00:10 +0100

csiph-web