Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1555829

Re: [PATCH v3 4/7] mtd: nand: raw: prefix conflicting names with nandc instead of nand

From Marek Vasut <marek.vasut@gmail.com>
Newsgroups linux.kernel
Subject Re: [PATCH v3 4/7] mtd: nand: raw: prefix conflicting names with nandc instead of nand
Date 2017-01-10 20:20 +0100
Message-ID <sYa7D-5fe-1@gated-at.bofh.it> (permalink)
References <sFWcN-1f8-3@gated-at.bofh.it> <sFWcO-1f8-35@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On 11/21/2016 01:45 PM, Boris Brezillon wrote:
> Some raw NAND function names conflict with names defined in nand.h.
> Prefix all those functions with nandc (for nand chip) instead of nand so
> we can include nand.h from rawnand.h
> 
> Signed-off-by: Boris Brezillon <boris.brezillon@free-electrons.com>

Nit, nand and nandc is quite confusing, why not call it nand_chip in full?

-- 
Best regards,
Marek Vasut

Back to linux.kernel | Previous | NextNext in thread | Find similar | Unroll thread


Thread

Re: [PATCH v3 4/7] mtd: nand: raw: prefix conflicting names with  nandc instead of nand Marek Vasut <marek.vasut@gmail.com> - 2017-01-10 20:20 +0100
  Re: [PATCH v3 4/7] mtd: nand: raw: prefix conflicting names with  nandc instead of nand Boris Brezillon <boris.brezillon@free-electrons.com> - 2017-01-11 08:50 +0100
    Re: [PATCH v3 4/7] mtd: nand: raw: prefix conflicting names with  nandc instead of nand Marek Vasut <marek.vasut@gmail.com> - 2017-01-11 13:10 +0100
      Re: [PATCH v3 4/7] mtd: nand: raw: prefix conflicting names with  nandc instead of nand Boris Brezillon <boris.brezillon@free-electrons.com> - 2017-01-11 13:40 +0100
        Re: [PATCH v3 4/7] mtd: nand: raw: prefix conflicting names with  nandc instead of nand Boris Brezillon <boris.brezillon@free-electrons.com> - 2017-01-11 14:20 +0100
          Re: [PATCH v3 4/7] mtd: nand: raw: prefix conflicting names with  nandc instead of nand Marek Vasut <marek.vasut@gmail.com> - 2017-01-11 14:30 +0100
        Re: [PATCH v3 4/7] mtd: nand: raw: prefix conflicting names with  nandc instead of nand Marek Vasut <marek.vasut@gmail.com> - 2017-01-11 14:20 +0100

csiph-web