Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1554260

Re: [patch] mm, thp: add new background defrag option

From Vlastimil Babka <vbabka@suse.cz>
Newsgroups linux.kernel
Subject Re: [patch] mm, thp: add new background defrag option
Date 2017-01-09 13:10 +0100
Message-ID <sXGVX-40B-15@gated-at.bofh.it> (permalink)
References (2 earlier) <sWgKd-3NE-15@gated-at.bofh.it> <sWpaO-Tr-3@gated-at.bofh.it> <sWyxr-7IH-25@gated-at.bofh.it> <sWLbl-8oT-63@gated-at.bofh.it> <sXF3Q-2PI-17@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On 01/09/2017 11:04 AM, Vlastimil Babka wrote:
> On 01/06/2017 11:20 PM, David Rientjes wrote:
>> I'd leave it to Andrew to decide whether sysfs files should accept 
>> multiple modes or not.  If you are to propose a patch to do so, I'd 
>> encourage you to do the same cleanup of triple_flag_store() that I did and 
>> make the gfp mask construction more straight-forward.  If you'd like to 
>> suggest a different name for "background", I'd be happy to change that if 
>> it's more descriptive.
> 
> Suggestion is above. I however think your cleanup isn't really needed,
> we can simply keep the existing 3 internal flags, and "madvise+defer"
> would enable two of them, like in my patch. Nothing says that internally
> each option should correspond to exactly one flag.

Forgot to add that if/when you repost this, please CC linux-api and
summarize what else was considered in the changelog. Thanks.

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[patch] mm, thp: add new background defrag option David Rientjes <rientjes@google.com> - 2017-01-05 00:50 +0100
  Re: [patch] mm, thp: add new background defrag option Mel Gorman <mgorman@techsingularity.net> - 2017-01-05 11:20 +0100
    Re: [patch] mm, thp: add new background defrag option Michal Hocko <mhocko@kernel.org> - 2017-01-05 11:40 +0100
    Re: [patch] mm, thp: add new background defrag option Vlastimil Babka <vbabka@suse.cz> - 2017-01-05 15:00 +0100
      Re: [patch] mm, thp: add new background defrag option Michal Hocko <mhocko@kernel.org> - 2017-01-05 17:00 +0100
      Re: [patch] mm, thp: add new background defrag option David Rientjes <rientjes@google.com> - 2017-01-06 00:00 +0100
        Re: [patch] mm, thp: add new background defrag option Vlastimil Babka <vbabka@suse.cz> - 2017-01-06 10:00 +0100
          Re: [patch] mm, thp: add new background defrag option Michal Hocko <mhocko@kernel.org> - 2017-01-06 15:10 +0100
          Re: [patch] mm, thp: add new background defrag option David Rientjes <rientjes@google.com> - 2017-01-06 23:30 +0100
            Re: [patch] mm, thp: add new background defrag option Vlastimil Babka <vbabka@suse.cz> - 2017-01-09 11:10 +0100
              Re: [patch] mm, thp: add new background defrag option Vlastimil Babka <vbabka@suse.cz> - 2017-01-09 13:10 +0100
              Re: [patch] mm, thp: add new background defrag option David Rientjes <rientjes@google.com> - 2017-01-10 03:30 +0100
                Re: [patch] mm, thp: add new background defrag option Hugh Dickins <hughd@google.com> - 2017-01-10 04:40 +0100
                Re: [patch] mm, thp: add new background defrag option Vlastimil Babka <vbabka@suse.cz> - 2017-01-10 09:50 +0100
                Re: [patch] mm, thp: add new background defrag option David Rientjes <rientjes@google.com> - 2017-01-11 01:00 +0100
                Re: [patch] mm, thp: add new background defrag option Michal Hocko <mhocko@kernel.org> - 2017-01-10 14:10 +0100
                [patch v2] mm, thp: add new defer+madvise defrag option David Rientjes <rientjes@google.com> - 2017-01-11 01:20 +0100
                Re: [patch v2] mm, thp: add new defer+madvise defrag option Vlastimil Babka <vbabka@suse.cz> - 2017-01-11 08:40 +0100
                Re: [patch v2] mm, thp: add new defer+madvise defrag option Michal Hocko <mhocko@kernel.org> - 2017-01-12 09:10 +0100
                Re: [patch v2] mm, thp: add new defer+madvise defrag option Mel Gorman <mgorman@techsingularity.net> - 2017-01-11 10:00 +0100
                Re: [patch v2] mm, thp: add new defer+madvise defrag option Andrew Morton <akpm@linux-foundation.org> - 2017-01-12 01:20 +0100

csiph-web