Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1543526
| From | Thomas Huth <thuth@redhat.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 08/11] powerpc/kvm: KVM-HV HPT resizing stub implementation |
| Date | 2016-12-16 16:40 +0100 |
| Message-ID | <sP2M1-5uf-5@gated-at.bofh.it> (permalink) |
| References | <sOxfb-1X8-5@gated-at.bofh.it> <sOxoS-2hi-19@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 15.12.2016 06:54, David Gibson wrote: > This patch adds a stub (always failing) implementation of the ioctl()s > for the HPT resizing PAPR extension. > > Signed-off-by: David Gibson <david@gibson.dropbear.id.au> > --- > arch/powerpc/include/asm/kvm_ppc.h | 4 ++++ > arch/powerpc/kvm/book3s_64_mmu_hv.c | 16 ++++++++++++++++ > arch/powerpc/kvm/book3s_hv.c | 22 ++++++++++++++++++++++ > 3 files changed, 42 insertions(+) I think I'd just squash this with the patch where you do the real implementation. Thomas
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH 00/11] KVM implementation of PAPR HPT resizing extension David Gibson <david@gibson.dropbear.id.au> - 2016-12-15 07:10 +0100
[PATCH 03/11] powerpc/kvm: Gather HPT related variables into sub-structure David Gibson <david@gibson.dropbear.id.au> - 2016-12-15 07:10 +0100
Re: [PATCH 03/11] powerpc/kvm: Gather HPT related variables into sub-structure Thomas Huth <thuth@redhat.com> - 2016-12-16 10:30 +0100
Re: [PATCH 03/11] powerpc/kvm: Gather HPT related variables into sub-structure David Gibson <david@gibson.dropbear.id.au> - 2016-12-19 03:10 +0100
[PATCH 07/11] powerpc/kvm: Create kvmppc_unmap_hpte_helper() David Gibson <david@gibson.dropbear.id.au> - 2016-12-15 07:10 +0100
Re: [PATCH 07/11] powerpc/kvm: Create kvmppc_unmap_hpte_helper() Thomas Huth <thuth@redhat.com> - 2016-12-16 14:00 +0100
[PATCH 06/11] powerpc/kvm: Allow KVM_PPC_ALLOCATE_HTAB ioctl() to change HPT size David Gibson <david@gibson.dropbear.id.au> - 2016-12-15 07:10 +0100
Re: [PATCH 06/11] powerpc/kvm: Allow KVM_PPC_ALLOCATE_HTAB ioctl() to change HPT size Thomas Huth <thuth@redhat.com> - 2016-12-16 13:50 +0100
Re: [PATCH 06/11] powerpc/kvm: Allow KVM_PPC_ALLOCATE_HTAB ioctl() to change HPT size David Gibson <david@gibson.dropbear.id.au> - 2016-12-19 03:10 +0100
Re: [PATCH 06/11] powerpc/kvm: Allow KVM_PPC_ALLOCATE_HTAB ioctl() to change HPT size Thomas Huth <thuth@redhat.com> - 2016-12-19 08:50 +0100
Re: [PATCH 06/11] powerpc/kvm: Allow KVM_PPC_ALLOCATE_HTAB ioctl() to change HPT size David Gibson <david@gibson.dropbear.id.au> - 2016-12-20 00:20 +0100
[PATCH 05/11] powerpc/kvm: Split HPT allocation from activation David Gibson <david@gibson.dropbear.id.au> - 2016-12-15 07:10 +0100
Re: [PATCH 05/11] powerpc/kvm: Split HPT allocation from activation Thomas Huth <thuth@redhat.com> - 2016-12-16 13:00 +0100
Re: [PATCH 05/11] powerpc/kvm: Split HPT allocation from activation David Gibson <david@gibson.dropbear.id.au> - 2016-12-19 03:10 +0100
[PATCH 04/11] powerpc/kvm: Don't store values derivable from HPT order David Gibson <david@gibson.dropbear.id.au> - 2016-12-15 07:10 +0100
Re: [PATCH 04/11] powerpc/kvm: Don't store values derivable from HPT order Thomas Huth <thuth@redhat.com> - 2016-12-16 11:40 +0100
Re: [PATCH 04/11] powerpc/kvm: Don't store values derivable from HPT order David Gibson <david@gibson.dropbear.id.au> - 2016-12-19 03:10 +0100
[PATCH 02/11] powerpc/kvm: Rename kvm_alloc_hpt() for clarity David Gibson <david@gibson.dropbear.id.au> - 2016-12-15 07:10 +0100
Re: [PATCH 02/11] powerpc/kvm: Rename kvm_alloc_hpt() for clarity Thomas Huth <thuth@redhat.com> - 2016-12-16 10:10 +0100
[PATCH 08/11] powerpc/kvm: KVM-HV HPT resizing stub implementation David Gibson <david@gibson.dropbear.id.au> - 2016-12-15 07:10 +0100
Re: [PATCH 08/11] powerpc/kvm: KVM-HV HPT resizing stub implementation Thomas Huth <thuth@redhat.com> - 2016-12-16 16:40 +0100
csiph-web