Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1541753

[PATCH] 9p: safer definition of P9_NOTAG and P9_NOFID

From Greg Kurz <groug@kaod.org>
Newsgroups linux.kernel
Subject [PATCH] 9p: safer definition of P9_NOTAG and P9_NOFID
Date 2016-12-14 09:30 +0100
Message-ID <sOd6N-49f-1@gated-at.bofh.it> (permalink)
Organization linux.* mail to news gateway

Show all headers | View raw


Both defines should at least have enclosing parenthesis to be usable in
any syntactical situation. This is the case of U16_MAX and U32_MAX, so
let's use them.

This patch is just cleanup, it doesn't change any behaviour with the current
code.

Signed-off-by: Greg Kurz <groug@kaod.org>
---
 include/net/9p/9p.h |    4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/include/net/9p/9p.h b/include/net/9p/9p.h
index 27dfe85772b1..5c80d98126b3 100644
--- a/include/net/9p/9p.h
+++ b/include/net/9p/9p.h
@@ -332,8 +332,8 @@ enum p9_qid_t {
 };
 
 /* 9P Magic Numbers */
-#define P9_NOTAG	(u16)(~0)
-#define P9_NOFID	(u32)(~0)
+#define P9_NOTAG	U16_MAX
+#define P9_NOFID	U32_MAX
 #define P9_MAXWELEM	16
 
 /* ample room for Twrite/Rread header */

Back to linux.kernel | Previous | Next | Find similar | Unroll thread


Thread

[PATCH] 9p: safer definition of P9_NOTAG and P9_NOFID Greg Kurz <groug@kaod.org> - 2016-12-14 09:30 +0100

csiph-web