Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1537025

Re: [PATCH v3 1/2] ARM: dts: da850-lcdk: add the dumb-vga-dac node

From Bartosz Golaszewski <bgolaszewski@baylibre.com>
Newsgroups linux.kernel
Subject Re: [PATCH v3 1/2] ARM: dts: da850-lcdk: add the dumb-vga-dac node
Date 2016-12-06 16:10 +0100
Message-ID <sLpxw-3FC-15@gated-at.bofh.it> (permalink)
References <sIPeN-7XO-9@gated-at.bofh.it> <sIPeO-7XO-27@gated-at.bofh.it> <sL129-4GU-3@gated-at.bofh.it> <sLnFo-2su-39@gated-at.bofh.it> <sLpxw-3FC-17@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


2016-12-06 16:03 GMT+01:00 Sekhar Nori <nsekhar@ti.com>:
> On Tuesday 06 December 2016 06:32 PM, Bartosz Golaszewski wrote:
>> 2016-12-05 13:49 GMT+01:00 Tomi Valkeinen <tomi.valkeinen@ti.com>:
>>> On 29/11/16 13:57, Bartosz Golaszewski wrote:
>>>> Add the dumb-vga-dac node to the board DT together with corresponding
>>>> ports and vga connector. This allows to retrieve the edid info from
>>>> the display automatically.
>>>>
>>>
>>> It's a bit difficult to follow this as there's been so many patches
>>> going around. But I take the above is the LCDC node in the base da850
>>> dtsi file? In that case, what is the display_in supposed to present?
>>> It's the first node in the "display chain", so it has no input.
>>>
>>> Also, don't touch da850.dtsi here, just add the "ports" node in the
>>> da850-lcdk.dts file.
>>>
>>> If the da850.dtsi has not been merged yet, I'd change the name of the
>>> lcdc node to something else than "display". It's rather vague. If it's
>>> named "lcdc", reading da850-lcdk.dts becomes much easier, as you'll
>>> refer to "lcdc".
>>>
>>
>> The node is already in Sekhar's branch.
>
> The node name should be 'display' as thats the ePAPR 1.1 generic name
> recommendation. The label is also set to 'display' though and that can
> be changed to lcdc.
>
> A pre-patch to fix that before we modify the node further is welcome.
>
> Thanks,
> Sekhar

I'll include this in v5 together with the change requested by Laurent.

Thanks,
Bartosz

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v3 0/2] ARM: dts: da850: tilcdc related DT changes Bartosz Golaszewski <bgolaszewski@baylibre.com> - 2016-11-29 13:00 +0100
  [PATCH v3 1/2] ARM: dts: da850-lcdk: add the dumb-vga-dac node Bartosz Golaszewski <bgolaszewski@baylibre.com> - 2016-11-29 13:00 +0100
    Re: [PATCH v3 1/2] ARM: dts: da850-lcdk: add the dumb-vga-dac node Tomi Valkeinen <tomi.valkeinen@ti.com> - 2016-12-05 14:00 +0100
      Re: [PATCH v3 1/2] ARM: dts: da850-lcdk: add the dumb-vga-dac node Bartosz Golaszewski <bgolaszewski@baylibre.com> - 2016-12-06 14:10 +0100
        Re: [PATCH v3 1/2] ARM: dts: da850-lcdk: add the dumb-vga-dac node Bartosz Golaszewski <bgolaszewski@baylibre.com> - 2016-12-06 16:10 +0100
        Re: [PATCH v3 1/2] ARM: dts: da850-lcdk: add the dumb-vga-dac node Sekhar Nori <nsekhar@ti.com> - 2016-12-06 16:20 +0100
    Re: [PATCH v3 1/2] ARM: dts: da850-lcdk: add the dumb-vga-dac node Rob Herring <robh+dt@kernel.org> - 2016-12-05 15:50 +0100

csiph-web