Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1536221

Re: [PATCH] vt: fix Scroll Lock LED trigger name

From Samuel Thibault <samuel.thibault@ens-lyon.org>
Newsgroups linux.kernel
Subject Re: [PATCH] vt: fix Scroll Lock LED trigger name
Date 2016-12-05 17:30 +0100
Message-ID <sL4jo-6RL-33@gated-at.bofh.it> (permalink)
References <sDW7g-3AY-21@gated-at.bofh.it> <sL1Ox-5co-5@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Hello,

Pavel Machek, on Mon 05 Dec 2016 14:47:43 +0100, wrote:
> > There is a disagreement between drivers/tty/vt/keyboard.c and
> > drivers/input/input-leds.c with regard to what is a Scroll Lock LED
> > trigger name: input calls it "kbd-scrolllock", but vt calls it
> > "kbd-scrollock" (two l's).
> > This prevents Scroll Lock LED trigger from binding to this LED by default.
> > 
> > Since it is a scroLL Lock LED, this interface was introduced only about a
> > year ago and in an Internet search people seem to reference this trigger
> > only to set it to this LED let's simply rename it to "kbd-scrolllock".
> > 
> > Also, it looks like this was supposed to be changed before this code was
> > merged: https://lkml.org/lkml/2015/6/9/697 but it was done only on
> > the input side.
> > 
> > Signed-off-by: Maciej S. Szmigiero <mail@maciej.szmigiero.name>
> > ---
> >  drivers/tty/vt/keyboard.c | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> > 
> > diff --git a/drivers/tty/vt/keyboard.c b/drivers/tty/vt/keyboard.c
> > index d5d81d4d3c04..3dd6a491cdba 100644
> > --- a/drivers/tty/vt/keyboard.c
> > +++ b/drivers/tty/vt/keyboard.c
> > @@ -982,7 +982,7 @@ static void kbd_led_trigger_activate(struct led_classdev *cdev)
> >  	KBD_LED_TRIGGER((_led_bit) + 8, _name)
> >  
> >  static struct kbd_led_trigger kbd_led_triggers[] = {
> > -	KBD_LED_TRIGGER(VC_SCROLLOCK, "kbd-scrollock"),
> > +	KBD_LED_TRIGGER(VC_SCROLLOCK, "kbd-scrolllock"),
> 
> Would it be feasible to rename "VC_SCROLLOCK" to "VC_SCROLLLOCK", too?

Well, no, that's a misnamed userland API.

Samuel

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

Re: [PATCH] vt: fix Scroll Lock LED trigger name Pavel Machek <pavel@ucw.cz> - 2016-12-05 14:50 +0100
  Re: [PATCH] vt: fix Scroll Lock LED trigger name Samuel Thibault <samuel.thibault@ens-lyon.org> - 2016-12-05 17:30 +0100

csiph-web