Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1535152
| From | Fabian Frederick <fabf@skynet.be> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 4/8 linux-next] libnvdimm, namespace: avoid multiple sector calculations |
| Date | 2016-12-02 20:30 +0100 |
| Message-ID | <sK1GW-7VR-31@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
add cleared_sectors variable to add more readability.
Signed-off-by: Fabian Frederick <fabf@skynet.be>
---
drivers/nvdimm/pmem.c | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers/nvdimm/pmem.c b/drivers/nvdimm/pmem.c
index 204912c..4da4735 100644
--- a/drivers/nvdimm/pmem.c
+++ b/drivers/nvdimm/pmem.c
@@ -52,16 +52,16 @@ static int pmem_clear_poison(struct pmem_device *pmem, phys_addr_t offset,
{
struct device *dev = to_dev(pmem);
sector_t sector;
- long cleared;
+ long cleared, cleared_sectors;
sector = (offset - pmem->data_offset) / 512;
cleared = nvdimm_clear_poison(dev, pmem->phys_addr + offset, len);
-
- if (cleared > 0 && cleared / 512) {
+ cleared_sectors = cleared / 512;
+ if (cleared > 0 && cleared_sectors) {
dev_dbg(dev, "%s: %#llx clear %ld sector%s\n",
- __func__, (unsigned long long) sector,
- cleared / 512, cleared / 512 > 1 ? "s" : "");
- badblocks_clear(&pmem->bb, sector, cleared / 512);
+ __func__, (unsigned long long) sector,
+ cleared_sectors, cleared_sectors > 1 ? "s" : "");
+ badblocks_clear(&pmem->bb, sector, cleared_sectors);
} else {
return -EIO;
}
--
2.7.4
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
[PATCH 4/8 linux-next] libnvdimm, namespace: avoid multiple sector calculations Fabian Frederick <fabf@skynet.be> - 2016-12-02 20:30 +0100 Re: [PATCH 4/8 linux-next] libnvdimm, namespace: avoid multiple sector calculations Dan Williams <dan.j.williams@intel.com> - 2016-12-02 21:20 +0100
csiph-web