Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1534778

Re: [PATCH v2] ia64: move cacheinfo sysfs to generic cacheinfo infrastructure

From Hanjun Guo <hanjun.guo@linaro.org>
Newsgroups linux.kernel
Subject Re: [PATCH v2] ia64: move cacheinfo sysfs to generic cacheinfo infrastructure
Date 2016-12-02 11:00 +0100
Message-ID <sJSNj-29y-11@gated-at.bofh.it> (permalink)
References <sJB05-5a9-1@gated-at.bofh.it> <sJB9M-5sv-23@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On 2016/12/1 23:08, Sudeep Holla wrote:
> This patch removes the redundant sysfs cacheinfo code by reusing
> the recently introduced generic cacheinfo infrastructure through the
> commit 246246cbde5e ("drivers: base: support cpu cache information
> interface to userspace via sysfs")
>
> Signed-off-by: Sudeep Holla <sudeep.holla@arm.com>
> Cc: Tony Luck <tony.luck@intel.com>
> Cc: Fenghua Yu <fenghua.yu@intel.com>
> Cc: Hanjun Guo <hanjun.guo@linaro.org>
> Cc: linux-ia64@vger.kernel.org
> ---
>  arch/ia64/kernel/topology.c | 384 ++++++++++++++------------------------------
>  1 file changed, 117 insertions(+), 267 deletions(-)
>
> v1->v2:
> 	- Rebased on top -next that has a patch introducing
> 	  cpu_map_populated
> 	- Also added SMP related macros that I missed in v1
> Hi,
>
> This is repost of the patch that was posted before several times to
> remove duplicate code. Since I don't have the platform to test, I was
> hoping to get some testing. This time Hanjun has kindly agreed to do
> some testing. Thanks a lot Hanjun in advance. You need to base this on
> top linux-next as there are few patches there. Take your time as this is
> not urgent at all.

You are welcome, I will test it next week :)

Thanks
Hanjun

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH] ia64: move cacheinfo sysfs to generic cacheinfo infrastructure Sudeep Holla <sudeep.holla@arm.com> - 2016-12-01 16:00 +0100
  [PATCH v2] ia64: move cacheinfo sysfs to generic cacheinfo infrastructure Sudeep Holla <sudeep.holla@arm.com> - 2016-12-01 16:10 +0100
    Re: [PATCH v2] ia64: move cacheinfo sysfs to generic cacheinfo  infrastructure Hanjun Guo <hanjun.guo@linaro.org> - 2016-12-02 11:00 +0100

csiph-web