Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1532052

RE: [PATCH v3] crypto: add virtio-crypto driver

From "Gonglei (Arei)" <arei.gonglei@huawei.com>
Newsgroups linux.kernel
Subject RE: [PATCH v3] crypto: add virtio-crypto driver
Date 2016-11-29 10:40 +0100
Message-ID <sIN3k-6FC-55@gated-at.bofh.it> (permalink)
References (1 earlier) <sIt4B-1Zr-1@gated-at.bofh.it> <sIwYy-4nX-23@gated-at.bofh.it> <sIxUC-52k-35@gated-at.bofh.it> <sILXz-5RH-19@gated-at.bofh.it> <sIMTE-6Co-31@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


> 
> On Tue, Nov 29, 2016 at 08:22:58AM +0000, Gonglei (Arei) wrote:
> > Hi,
> >
> > > > > > +source "drivers/crypto/virtio/Kconfig"
> > > > > > +
> > > > > >  endif # CRYPTO_HW
> > > > > > diff --git a/drivers/crypto/Makefile b/drivers/crypto/Makefile
> > > > > > index ad7250f..bc53cb8 100644
> > > > > > --- a/drivers/crypto/Makefile
> > > > > > +++ b/drivers/crypto/Makefile
> > > > > > @@ -32,3 +32,4 @@ obj-$(CONFIG_CRYPTO_DEV_VMX) += vmx/
> > > > > >  obj-$(CONFIG_CRYPTO_DEV_SUN4I_SS) += sunxi-ss/
> > > > > >  obj-$(CONFIG_CRYPTO_DEV_ROCKCHIP) += rockchip/
> > > > > >  obj-$(CONFIG_CRYPTO_DEV_CHELSIO) += chelsio/
> > > > > > +obj-$(CONFIG_CRYPTO_DEV_VIRTIO) += virtio/
> > > > > > diff --git a/drivers/crypto/virtio/Kconfig b/drivers/crypto/virtio/Kconfig
> > > > > > new file mode 100644
> > > > > > index 0000000..ceae88c
> > > > > > --- /dev/null
> > > > > > +++ b/drivers/crypto/virtio/Kconfig
> > > > > > @@ -0,0 +1,10 @@
> > > > > > +config CRYPTO_DEV_VIRTIO
> > > > > > +	tristate "VirtIO crypto driver"
> > > > > > +	depends on VIRTIO
> > > > > > +    select CRYPTO_AEAD
> > > > > > +    select CRYPTO_AUTHENC
> > > > > > +    select CRYPTO_BLKCIPHER
> > > > >
> > > > > Inconsistent tab vs space whitespace usage.
> > > > >
> > > Will fix.
> > >
> > > > > > +	default m
> > > > > > +	help
> > > > > > +	  This driver provides support for virtio crypto device. If you
> > > > > > +	  choose 'M' here, this module will be called virtio-crypto.
> > > > >
> > > > > All the other virtio drivers use underscore ('_') instead of hyphen
> > > > > ('-').
> > > >
> > > > Except virtio-rng.
> > > >
> > > > >  I suggest calling it virtio_crypto for consistency.
> > > > >
> > > OK, I will change the Makefile to fix it.
> > >
> >
> > I tried to do this, but I failed. Because virtio_crypto.ko
> > consists of more than one source file which include tree files currently,
> > and virtio_crypto.ko matchs the name of virtio_crypto.c.
> > That's different with all other virtio drivers.
> 
> Can you rename virtio_crypto.c to virtio_crypto_core.c?
> 
I'm fine with virtio_crypto_core.c. What about you? Michael?

Regards,
-Gonglei

> I'm not very familiar with the kernel Makefile infrastructure so maybe
> there's a better way of doing it.
> 
> Stefan

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH v3] virtio-crypto: add Linux driver Gonglei <arei.gonglei@huawei.com> - 2016-11-28 13:20 +0100
  Re: [PATCH v3] crypto: add virtio-crypto driver Cornelia Huck <cornelia.huck@de.ibm.com> - 2016-11-28 14:20 +0100
    RE: [virtio-dev] Re: [PATCH v3] crypto: add virtio-crypto driver "Gonglei (Arei)" <arei.gonglei@huawei.com> - 2016-11-29 02:50 +0100
      Re: [virtio-dev] Re: [PATCH v3] crypto: add virtio-crypto driver Cornelia Huck <cornelia.huck@de.ibm.com> - 2016-11-29 10:50 +0100
        RE: [virtio-dev] Re: [PATCH v3] crypto: add virtio-crypto driver "Gonglei (Arei)" <arei.gonglei@huawei.com> - 2016-11-29 13:00 +0100
  Re: [PATCH v3] crypto: add virtio-crypto driver Halil Pasic <pasic@linux.vnet.ibm.com> - 2016-11-28 18:40 +0100
    RE: [PATCH v3] crypto: add virtio-crypto driver "Gonglei (Arei)" <arei.gonglei@huawei.com> - 2016-11-29 04:50 +0100
  RE: [PATCH v3] crypto: add virtio-crypto driver "Gonglei (Arei)" <arei.gonglei@huawei.com> - 2016-11-29 07:50 +0100
  RE: [PATCH v3] crypto: add virtio-crypto driver "Gonglei (Arei)" <arei.gonglei@huawei.com> - 2016-11-29 09:30 +0100
    Re: [PATCH v3] crypto: add virtio-crypto driver Stefan Hajnoczi <stefanha@redhat.com> - 2016-11-29 10:30 +0100
      Re: [PATCH v3] crypto: add virtio-crypto driver Cornelia Huck <cornelia.huck@de.ibm.com> - 2016-11-29 10:40 +0100
        RE: [PATCH v3] crypto: add virtio-crypto driver "Gonglei (Arei)" <arei.gonglei@huawei.com> - 2016-11-29 12:50 +0100
      RE: [PATCH v3] crypto: add virtio-crypto driver "Gonglei (Arei)" <arei.gonglei@huawei.com> - 2016-11-29 10:40 +0100

csiph-web