Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1532037
| From | Ingo Molnar <mingo@kernel.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v12 2/7] x86/arch_prctl/64: Rename do_arch_prctl to do_arch_prctl_64 |
| Date | 2016-11-29 10:30 +0100 |
| Message-ID | <sIMTE-6Co-39@gated-at.bofh.it> (permalink) |
| References | <sEkjg-2JC-3@gated-at.bofh.it> <sEkjg-2JC-7@gated-at.bofh.it> <sELMt-40C-5@gated-at.bofh.it> <sEUmJ-18a-27@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
* Kyle Huey <me@kylehuey.com> wrote: > On Thu, Nov 17, 2016 at 11:27 PM, Ingo Molnar <mingo@kernel.org> wrote: > > > > * Kyle Huey <me@kylehuey.com> wrote: > > > >> In order to introduce new arch_prctls that are not 64 bit only, rename the > >> existing 64 bit implementation to do_arch_prctl_64(). Also rename the second > >> argument to arch_prctl(), which will no longer always be an address. > > > >> #ifdef CONFIG_X86_64 > >> void entry_SYSCALL_64(void); > >> +long do_arch_prctl_64(struct task_struct *task, int code, unsigned long arg2); > >> #endif > > > > Could you please also rename the weirdly named 'code' argument to 'option', > > to be in line with the existing sys_prctl() interface nomenclature? > > arch_prctl consistently uses 'code' throughout the kernel and in the > main page. This renaming should probably be done separately if > desired. 'arch_prctl' is essentially an x86-ism that arbitrarily changed 'option' to 'code' to implement a sub-option where the option was indeed 'code' - but with _your_ changes it becomes outright misleading and confusing: as the 'code' is not code anymore but one of the several options. The core kernel uses 'option' and we should follow that nomenclature. Thanks, Ingo
Back to linux.kernel | Previous | Next | Find similar | Unroll thread
Re: [PATCH v12 2/7] x86/arch_prctl/64: Rename do_arch_prctl to do_arch_prctl_64 Ingo Molnar <mingo@kernel.org> - 2016-11-29 10:30 +0100
csiph-web