Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1531839

Re: [PATCH V4 07/10] PM / OPP: Separate out _generic_opp_set_rate()

From Stephen Boyd <sboyd@codeaurora.org>
Newsgroups linux.kernel
Subject Re: [PATCH V4 07/10] PM / OPP: Separate out _generic_opp_set_rate()
Date 2016-11-29 02:20 +0100
Message-ID <sIFfs-1lT-3@gated-at.bofh.it> (permalink)
References <sH0xH-218-3@gated-at.bofh.it> <sH0xH-218-1@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On 11/24, Viresh Kumar wrote:
> Later patches would add support for custom opp_set_rate callbacks. This
> patch separates out the code for generic opp_set_rate handler in order
> to prepare for that.

s/opp_set_rate/set_opp/ twice?

> 
> Signed-off-by: Viresh Kumar <viresh.kumar@linaro.org>
> Tested-by: Dave Gerlach <d-gerlach@ti.com>
> ---

Besides the naming confusion.

Reviewed-by: Stephen Boyd <sboyd@codeaurora.org>

> @@ -1422,6 +1488,11 @@ int dev_pm_opp_set_regulators(struct device *dev, const char * const names[],
>  
>  	opp_table->regulator_count = count;
>  
> +	/* Allocate block only once to pass to ->set_rate() */

_generic_set_opp()? Or just set_opp when that gets introduced in
the next patch.

> +	ret = _allocate_set_opp_data(opp_table);
> +	if (ret)
> +		goto free_regulators;
> +
>  	mutex_unlock(&opp_table_lock);
>  	return 0;
>  

-- 
Qualcomm Innovation Center, Inc. is a member of Code Aurora Forum,
a Linux Foundation Collaborative Project

Back to linux.kernel | Previous | Next | Find similar | Unroll thread


Thread

Re: [PATCH V4 07/10] PM / OPP: Separate out _generic_opp_set_rate() Stephen Boyd <sboyd@codeaurora.org> - 2016-11-29 02:20 +0100

csiph-web