Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1528263
| From | Mark Rutland <mark.rutland@arm.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCHv3 5/6] arm64: Use __pa_symbol for kernel symbols |
| Date | 2016-11-23 11:00 +0100 |
| Message-ID | <sGCvn-3a3-13@gated-at.bofh.it> (permalink) |
| References | <sEG0p-7y-3@gated-at.bofh.it> <sEG0p-7y-1@gated-at.bofh.it> <sESuB-8nd-9@gated-at.bofh.it> <sG0T8-4em-45@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Mon, Nov 21, 2016 at 09:40:06AM -0800, Laura Abbott wrote: > On 11/18/2016 06:35 AM, Mark Rutland wrote: > > On Thu, Nov 17, 2016 at 05:16:55PM -0800, Laura Abbott wrote: > >> /* Grab the vDSO code pages. */ > >> for (i = 0; i < vdso_pages; i++) > >> - vdso_pagelist[i + 1] = pfn_to_page(PHYS_PFN(__pa(&vdso_start)) + i); > >> + vdso_pagelist[i + 1] = pfn_to_page(PHYS_PFN(__pa_symbol(&vdso_start)) + i); > > > > Nit: phys_to_page() again. > > I think it makes sense to keep this one as is. It's offsetting > by pfn number and trying force phys_to_page would make it more > difficult to read. My bad; I failed to spot the + i. That sounds good to me; sorry for the noise there. Thanks, Mark.
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCHv3 5/6] arm64: Use __pa_symbol for kernel symbols Laura Abbott <labbott@redhat.com> - 2016-11-18 02:20 +0100
Re: [PATCHv3 5/6] arm64: Use __pa_symbol for kernel symbols Mark Rutland <mark.rutland@arm.com> - 2016-11-18 15:40 +0100
Re: [PATCHv3 5/6] arm64: Use __pa_symbol for kernel symbols Mark Rutland <mark.rutland@arm.com> - 2016-11-18 17:50 +0100
Re: [PATCHv3 5/6] arm64: Use __pa_symbol for kernel symbols Laura Abbott <labbott@redhat.com> - 2016-11-21 18:50 +0100
Re: [PATCHv3 5/6] arm64: Use __pa_symbol for kernel symbols Mark Rutland <mark.rutland@arm.com> - 2016-11-23 11:00 +0100
csiph-web