Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1521613

[Patch v7 4/7] irqchip: xilinx: Rename get_irq to xintc_get_irq

From Zubair Lutfullah Kakakhel <Zubair.Kakakhel@imgtec.com>
Newsgroups linux.kernel
Subject [Patch v7 4/7] irqchip: xilinx: Rename get_irq to xintc_get_irq
Date 2016-11-14 13:20 +0100
Message-ID <sDooX-6ST-55@gated-at.bofh.it> (permalink)
References <sDooV-6ST-5@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Now that the driver is generic and used by multiple archs,
get_irq is too generic.

Rename get_irq to xintc_get_irq to avoid any conflicts

Signed-off-by: Zubair Lutfullah Kakakhel <Zubair.Kakakhel@imgtec.com>

---
V6 -> V7
Rebase to v4.9-rc5

V5 -> V6
Removed __func__ in printk
Rebase to v4.9-rc3

V4 -> V5
Rebased to v4.9-rc1
Use __func__ in pr_err

V3 -> V4
New patch.
---
 arch/microblaze/include/asm/irq.h | 2 +-
 arch/microblaze/kernel/irq.c      | 4 ++--
 drivers/irqchip/irq-xilinx-intc.c | 2 +-
 3 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/arch/microblaze/include/asm/irq.h b/arch/microblaze/include/asm/irq.h
index bab3b13..d785def 100644
--- a/arch/microblaze/include/asm/irq.h
+++ b/arch/microblaze/include/asm/irq.h
@@ -16,6 +16,6 @@ struct pt_regs;
 extern void do_IRQ(struct pt_regs *regs);
 
 /* should be defined in each interrupt controller driver */
-extern unsigned int get_irq(void);
+extern unsigned int xintc_get_irq(void);
 
 #endif /* _ASM_MICROBLAZE_IRQ_H */
diff --git a/arch/microblaze/kernel/irq.c b/arch/microblaze/kernel/irq.c
index 11e24de..903dad8 100644
--- a/arch/microblaze/kernel/irq.c
+++ b/arch/microblaze/kernel/irq.c
@@ -29,12 +29,12 @@ void __irq_entry do_IRQ(struct pt_regs *regs)
 	trace_hardirqs_off();
 
 	irq_enter();
-	irq = get_irq();
+	irq = xintc_get_irq();
 next_irq:
 	BUG_ON(!irq);
 	generic_handle_irq(irq);
 
-	irq = get_irq();
+	irq = xintc_get_irq();
 	if (irq != -1U) {
 		pr_debug("next irq: %d\n", irq);
 		++concurrent_irq;
diff --git a/drivers/irqchip/irq-xilinx-intc.c b/drivers/irqchip/irq-xilinx-intc.c
index 7331d8c..34ec609 100644
--- a/drivers/irqchip/irq-xilinx-intc.c
+++ b/drivers/irqchip/irq-xilinx-intc.c
@@ -101,7 +101,7 @@ static struct irq_chip intc_dev = {
 	.irq_mask_ack = intc_mask_ack,
 };
 
-unsigned int get_irq(void)
+unsigned int xintc_get_irq(void)
 {
 	unsigned int hwirq, irq = -1;
 
-- 
2.10.2

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[Patch v7 0/7] microblaze/PowerPC: Move irq-xilinx to irqchip Zubair Lutfullah Kakakhel <Zubair.Kakakhel@imgtec.com> - 2016-11-14 13:20 +0100
  [Patch v7 5/7] irqchip: xilinx: Add support for parent intc Zubair Lutfullah Kakakhel <Zubair.Kakakhel@imgtec.com> - 2016-11-14 13:20 +0100
  [Patch v7 1/7] microblaze: irqchip: Move intc driver to irqchip Zubair Lutfullah Kakakhel <Zubair.Kakakhel@imgtec.com> - 2016-11-14 13:20 +0100
  [Patch v7 2/7] irqchip: xilinx: clean up print messages Zubair Lutfullah Kakakhel <Zubair.Kakakhel@imgtec.com> - 2016-11-14 13:20 +0100
  [Patch v7 6/7] irqchip: xilinx: Try to fall back if xlnx,kind-of-intr not provided Zubair Lutfullah Kakakhel <Zubair.Kakakhel@imgtec.com> - 2016-11-14 13:20 +0100
    Re: [Patch v7 6/7] irqchip: xilinx: Try to fall back if xlnx,kind-of-intr  not provided Thomas Gleixner <tglx@linutronix.de> - 2016-11-18 14:40 +0100
      Re: [Patch v7 6/7] irqchip: xilinx: Try to fall back if  xlnx,kind-of-intr not provided Zubair Lutfullah Kakakhel <Zubair.Kakakhel@imgtec.com> - 2016-11-21 15:10 +0100
        Re: [Patch v7 6/7] irqchip: xilinx: Try to fall back if  xlnx,kind-of-intr not provided Marc Zyngier <marc.zyngier@arm.com> - 2016-11-21 15:20 +0100
          Re: [Patch v7 6/7] irqchip: xilinx: Try to fall back if  xlnx,kind-of-intr not provided Zubair Lutfullah Kakakhel <Zubair.Kakakhel@imgtec.com> - 2016-11-21 15:40 +0100
        Re: [Patch v7 6/7] irqchip: xilinx: Try to fall back if xlnx,kind-of-intr  not provided Thomas Gleixner <tglx@linutronix.de> - 2016-11-21 17:00 +0100
  [Patch v7 7/7] powerpc/virtex: Use generic xilinx irqchip driver Zubair Lutfullah Kakakhel <Zubair.Kakakhel@imgtec.com> - 2016-11-14 13:20 +0100
  [Patch v7 4/7] irqchip: xilinx: Rename get_irq to xintc_get_irq Zubair Lutfullah Kakakhel <Zubair.Kakakhel@imgtec.com> - 2016-11-14 13:20 +0100
  Re: [Patch v7 0/7] microblaze/PowerPC: Move irq-xilinx to irqchip Marc Zyngier <marc.zyngier@arm.com> - 2016-11-22 12:00 +0100
    Re: [Patch v7 0/7] microblaze/PowerPC: Move irq-xilinx to irqchip Zubair Lutfullah Kakakhel <Zubair.Kakakhel@imgtec.com> - 2016-11-22 12:20 +0100

csiph-web