Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1519261

Re: [tip:ras/core] x86/RAS: Simplify SMCA HWID descriptor struct

From Borislav Petkov <bp@suse.de>
Newsgroups linux.kernel
Subject Re: [tip:ras/core] x86/RAS: Simplify SMCA HWID descriptor struct
Date 2016-11-10 19:10 +0100
Message-ID <sC1Xx-1gl-39@gated-at.bofh.it> (permalink)
References <szpMC-3XC-33@gated-at.bofh.it> <sBhrz-3gP-7@gated-at.bofh.it> <sC1Xx-1gl-41@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Thu, Nov 10, 2016 at 12:50:04PM -0500, Yazen Ghannam wrote:
> Adding extra parentheses in HWID_MCATYPE() gives the same assembly as the
> original code and fixes the behavior.
> 
> > +	hwid_mcatype = HWID_MCATYPE((high & MCI_IPID_HWID)),
> > +				    ((high & MCI_IPID_MCATYPE) >> 16));

Argh, the macro should be adding the additional parentheses:

#define HWID_MCATYPE(hwid, mcatype) (((hwid) << 16) | (mcatype))

That should fix the issue too.

-- 
Regards/Gruss,
    Boris.

SUSE Linux GmbH, GF: Felix Imendörffer, Jane Smithard, Graham Norton, HRB 21284 (AG Nürnberg)
-- 

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 1/3] x86/RAS: Simplify SMCA bank descriptor struct Borislav Petkov <bp@alien8.de> - 2016-11-03 14:00 +0100
  [PATCH 2/3] x86/RAS: Simplify SMCA HWID descriptor struct Borislav Petkov <bp@alien8.de> - 2016-11-03 14:00 +0100
    [tip:ras/core] x86/RAS: Simplify SMCA HWID descriptor struct tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-11-08 17:30 +0100
      Re: [tip:ras/core] x86/RAS: Simplify SMCA HWID descriptor struct Borislav Petkov <bp@suse.de> - 2016-11-10 19:10 +0100
        Re: [tip:ras/core] x86/RAS: Simplify SMCA HWID descriptor struct Thomas Gleixner <tglx@linutronix.de> - 2016-11-10 21:00 +0100
  [PATCH 3/3] x86/RAS: Rename smca_bank_names to smca_names Borislav Petkov <bp@alien8.de> - 2016-11-03 14:00 +0100
    [tip:ras/core] x86/RAS: Rename smca_bank_names to smca_names tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-11-08 17:30 +0100
  Re: [PATCH 1/3] x86/RAS: Simplify SMCA bank descriptor struct Borislav Petkov <bp@alien8.de> - 2016-11-04 16:30 +0100
    [tip:ras/core] x86/RAS: Hide SMCA bank names tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-11-08 17:30 +0100
  [tip:ras/core] x86/RAS: Simplify SMCA bank descriptor struct tip-bot for Borislav Petkov <tipbot@zytor.com> - 2016-11-08 17:30 +0100

csiph-web