Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1518564
| From | "Jason A. Donenfeld" <Jason@zx2c4.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: Proposal: HAVE_SEPARATE_IRQ_STACK? |
| Date | 2016-11-10 00:40 +0100 |
| Message-ID | <sBKDf-5OO-1@gated-at.bofh.it> (permalink) |
| References | <sBIBr-4hw-9@gated-at.bofh.it> <sBIUO-4sZ-5@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Hey Thomas, On Wed, Nov 9, 2016 at 10:40 PM, Thomas Gleixner <tglx@linutronix.de> wrote: > That preempt_disable() prevents merily preemption as the name says, but it > wont prevent softirq handlers from running on return from interrupt. So > what's the point? Oh, interesting. Okay, then in that case the proposed define wouldn't be useful for my purposes. What clever tricks do I have at my disposal, then? >> If not, do you have a better solution for me (which doesn't >> involve using kmalloc or choosing a different crypto primitive)? > > What's wrong with using kmalloc? It's cumbersome and potentially slow. This is crypto code, where speed matters a lot. Avoiding allocations is usually the lowest hanging fruit among optimizations. To give you some idea, here's a somewhat horrible solution using kmalloc I hacked together: [1]. I'm not to happy with what it looks like, code-wise, and there's around a 16% slowdown, which isn't nice either. [1] https://git.zx2c4.com/WireGuard/commit/?h=jd/curve25519-kmalloc
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
Proposal: HAVE_SEPARATE_IRQ_STACK? "Jason A. Donenfeld" <Jason@zx2c4.com> - 2016-11-09 22:30 +0100
Re: Proposal: HAVE_SEPARATE_IRQ_STACK? Thomas Gleixner <tglx@linutronix.de> - 2016-11-09 22:50 +0100
Re: Proposal: HAVE_SEPARATE_IRQ_STACK? "Jason A. Donenfeld" <Jason@zx2c4.com> - 2016-11-10 00:40 +0100
Re: Proposal: HAVE_SEPARATE_IRQ_STACK? Thomas Gleixner <tglx@linutronix.de> - 2016-11-10 10:10 +0100
Re: Proposal: HAVE_SEPARATE_IRQ_STACK? "Jason A. Donenfeld" <Jason@zx2c4.com> - 2016-11-10 12:50 +0100
Re: Proposal: HAVE_SEPARATE_IRQ_STACK? Thomas Gleixner <tglx@linutronix.de> - 2016-11-10 14:10 +0100
Re: Proposal: HAVE_SEPARATE_IRQ_STACK? "Jason A. Donenfeld" <Jason@zx2c4.com> - 2016-11-10 18:50 +0100
Re: Proposal: HAVE_SEPARATE_IRQ_STACK? Matt Redfearn <matt.redfearn@imgtec.com> - 2016-11-10 17:40 +0100
Re: Proposal: HAVE_SEPARATE_IRQ_STACK? "Jason A. Donenfeld" <Jason@zx2c4.com> - 2016-11-10 18:40 +0100
Re: Proposal: HAVE_SEPARATE_IRQ_STACK? "Jason A. Donenfeld" <Jason@zx2c4.com> - 2016-11-10 02:50 +0100
csiph-web