Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1516464

Re: [PATCH v2] USB hub_probe: remove ugly goto-into-compound-statement

Path csiph.com!1.us.feeder.erje.net!feeder.erje.net!2.eu.feeder.erje.net!enother.net!enother.net!enother.net!newsfeed.datemas.de!weretis.net!feeder4.news.weretis.net!news.mixmin.net!aioe.org!bofh.it!news.nic.it!robomod
From Eugene Korenevsky <ekorenevsky@gmail.com>
Newsgroups linux.kernel
Subject Re: [PATCH v2] USB hub_probe: remove ugly goto-into-compound-statement
Date Mon, 07 Nov 2016 19:50:02 +0100
Message-ID <sAX9w-71s-29@gated-at.bofh.it> (permalink)
References <sz893-1fI-29@gated-at.bofh.it> <sAO6d-UV-9@gated-at.bofh.it>
X-Original-To Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Dkim-Signature v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113; h=date:from:to:cc:subject:message-id:references:mime-version :content-disposition:in-reply-to:user-agent; bh=rT1TcF3p6meYVBt7c5Fga/t+TS1d7P1848jaHQkp1VM=; b=VPSfskrlS4IZaLrO+qdfgOFRDRhera3TxvyVuafBY4A7PRB7bs6d5Cat8bEh4/WwHN QCDtPQrs2gejbyWXHq21qQNhu+Y0AwoWAzub+3vVr5Yqk5vfBka41hLKC8JQcXszbWZn jrJPDjr5KbY1N2hB6nWxJsxUolwzjEqWdN50/nUcbmiS6J2CiXePILNtYWYX/9LzZ2kK A7p9E4omSmLy0a8QDiJfEGUqqbRphTxg+11sea2VrzwIEPxJWLiwKku3+jtKWJ0ROAfD YDQlKQWCM8KZwbxQLfoG9iK8FfSVZb83b4hM4xXSoYL1PIeVXlhDSfRlacfx2Olw0BNo txSA==
X-Google-Dkim-Signature v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20130820; h=x-gm-message-state:date:from:to:cc:subject:message-id:references :mime-version:content-disposition:in-reply-to:user-agent; bh=rT1TcF3p6meYVBt7c5Fga/t+TS1d7P1848jaHQkp1VM=; b=D6jJ4/Ir/F+x/hDCkqbIsT8LH8xFn1W9pV9mY7vE4LkoDu2rEGWlvO33S6LlHYjQin i68rYQLmudpSi0SJthOdjMph2UsMjcKwD3B/avHwZFY/4jfyrPE8A/5SGNXDET54zAgr Eprc9qR0Uk0oSgJ23/qBpD6R++n9yWAVBs+GOMvSZkDF2j41zF8U/MviveSpAheWUqkn HNjhky71yq5kBSe730FVA8GZKtYDf3q1nxLJkGFDh8XfDtkHa73L0Qih9a5okRbc/9Mb g2gRLOrgHSigCHgCYpu/+9sbUpwyTclOI/sPnG9WpoM8U9KDaB6JmKBHZshtL0Vu8n3K fFdw==
X-Gm-Message-State ABUngve6h5bZcvWMHZWutbsA2bVxFWx4kPHfLs9A4YYv/4Yk2bSwqgsdw/eF4hHqH8472Q==
X-Received by 10.25.208.14 with SMTP id h14mr3272742lfg.73.1478544196874; Mon, 07 Nov 2016 10:43:16 -0800 (PST)
MIME-Version 1.0
Content-Type text/plain; charset=us-ascii
Content-Disposition inline
User-Agent Mutt/1.7.1 (2016-10-04)
Sender robomod@news.nic.it
List-ID <linux-kernel.vger.kernel.org>
X-Mailing-List linux-kernel@vger.kernel.org
Approved robomod@news.nic.it
Lines 63
Organization linux.* mail to news gateway
X-Original-Cc linux-kernel@vger.kernel.org, linux-usb@vger.kernel.org, Luiz Capitulino <lcapitulino@redhat.com>, Linus Torvalds <torvalds@linux-foundation.org>, Chase Metzger <chasemetzger15@gmail.com>, Alan Stern <stern@rowland.harvard.edu>, Mathias Nyman <mathias.nyman@linux.intel.com>, Lu Baolu <baolu.lu@linux.intel.com>, Oliver Neukum <oneukum@suse.com>, Hans Yang <hansy@nvidia.com>
X-Original-Date Mon, 7 Nov 2016 21:42:57 +0300
X-Original-Message-ID <20161107184256.GA18770@vnote>
X-Original-References <20161102175944.GA31229@vnote> <20161107090917.GA4949@kroah.com>
X-Original-Sender linux-kernel-owner@vger.kernel.org
Xref csiph.com linux.kernel:1516464

Show key headers only | View raw


On Mon, Nov 07, 2016 at 10:09:17AM +0100, Greg Kroah-Hartman wrote:

> > Rework smelling code (goto inside compound statement). Perhaps this is legacy.
> > Anyway such code is not appropriate for Linux kernel.
> > 
> > Signed-off-by: Eugene Korenevsky <ekorenevsky@gmail.com>
> > ---
> >  drivers/usb/core/hub.c | 24 +++++++++++-------------
> >  1 file changed, 11 insertions(+), 13 deletions(-)
> 
> What changed from v1?

Fixed faults: missed 'Signed-off-by', spaces instead of tab.


> > diff --git a/drivers/usb/core/hub.c b/drivers/usb/core/hub.c
> > index cbb1467..4081672 100644
> > --- a/drivers/usb/core/hub.c
> > +++ b/drivers/usb/core/hub.c
> > @@ -1802,23 +1802,21 @@ static int hub_probe(struct usb_interface *intf, const struct usb_device_id *id)
> >  
> >  	/* Some hubs have a subclass of 1, which AFAICT according to the */
> >  	/*  specs is not defined, but it works */
> > -	if ((desc->desc.bInterfaceSubClass != 0) &&
> > -	    (desc->desc.bInterfaceSubClass != 1)) {
> > -descriptor_error:
> > +
> > +	/* Reject in following cases:
> > +	 * - Interface subclass is not 0 or 1
> > +	 * - Multiple endpoints
> > +	 * - Not an interrupt in endpoint
> > +	 */
> > +	endpoint = &desc->endpoint[0].desc;
> > +	if ((desc->desc.bInterfaceSubClass != 0 &&
> > +	     desc->desc.bInterfaceSubClass != 1) ||
> > +	    desc->desc.bNumEndpoints != 1 ||
> > +	    !usb_endpoint_is_int_in(endpoint)) {
> >  		dev_err(&intf->dev, "bad descriptor, ignoring hub\n");
> >  		return -EIO;
> >  	}
> >  
> > -	/* Multiple endpoints? What kind of mutant ninja-hub is this? */
> > -	if (desc->desc.bNumEndpoints != 1)
> > -		goto descriptor_error;
> > -
> > -	endpoint = &desc->endpoint[0].desc;
> > -
> > -	/* If it's not an interrupt in endpoint, we'd better punt! */
> > -	if (!usb_endpoint_is_int_in(endpoint))
> > -		goto descriptor_error;
> > -
> 
> As "horrible" as the original code might be, it's much easier to read
> and follow, which is the key thing here, right?  What's so bad about a
> goto backwards?

OK, this patch is still not perfect. But jumping *back* into
*compound* *statement* hurts reader's eyes. Really. Maybe it's better to
extract this code to static function, compiler will inline it. See v3
patchset.

-- 
Eugene

Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread


Thread

[PATCH v2] USB hub_probe: remove ugly goto-into-compound-statement Eugene Korenevsky <ekorenevsky@gmail.com> - 2016-11-02 19:10 +0100
  Re: [PATCH v2] USB hub_probe: remove ugly  goto-into-compound-statement Greg Kroah-Hartman <gregkh@linuxfoundation.org> - 2016-11-07 10:10 +0100
    Re: [PATCH v2] USB hub_probe: remove ugly  goto-into-compound-statement Eugene Korenevsky <ekorenevsky@gmail.com> - 2016-11-07 19:50 +0100

csiph-web