Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1465789
| From | Bjorn Andersson <bjorn.andersson@linaro.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 08/14] rpmsg: Split rpmsg core and virtio backend |
| Date | 2016-08-19 03:30 +0200 |
| Message-ID | <s7GNd-7nF-43@gated-at.bofh.it> (permalink) |
| References | <s6AgN-4eu-3@gated-at.bofh.it> <s6AgO-4eu-35@gated-at.bofh.it> <s7uiZ-82P-15@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Thu 18 Aug 04:59 PDT 2016, Loic PALLARDY wrote: > > > > -----Original Message----- > > From: linux-remoteproc-owner@vger.kernel.org [mailto:linux-remoteproc- > > owner@vger.kernel.org] On Behalf Of Bjorn Andersson > > Sent: Tuesday, August 16, 2016 2:17 AM > > To: Ohad Ben-Cohen <ohad@wizery.com>; Bjorn Andersson > > <bjorn.andersson@linaro.org> > > Cc: linux-remoteproc@vger.kernel.org; linux-arm-msm@vger.kernel.org; > > linux-arm-kernel@lists.infradead.org; linux-kernel@vger.kernel.org; > > Sricharan R <sricharan@codeaurora.org> > > Subject: [PATCH 08/14] rpmsg: Split rpmsg core and virtio backend > > > > Extract the generic rpmsg core functionality from the virtio rpmsg > > implementation, splitting the implementation in a rpmsg core and a > > virtio backend. > > > > Based on initial work by Sricharan R <sricharan@codeaurora.org> > > > > Cc: Sricharan R <sricharan@codeaurora.org> > > Signed-off-by: Bjorn Andersson <bjorn.andersson@linaro.org> > > --- > > drivers/rpmsg/Kconfig | 4 + > > drivers/rpmsg/Makefile | 3 +- > > drivers/rpmsg/rpmsg_core.c | 513 > > +++++++++++++++++++++++++++++++++++++++ > > drivers/rpmsg/rpmsg_internal.h | 45 ++++ > > drivers/rpmsg/virtio_rpmsg_bus.c | 477 +----------------------------------- > Hi Bjorn, > > Could you please regenerate the patch with option -M (of git > formatpatch) to detect file renames. It will provide better > visibility of differences between virtio_rpmsg_bus.c and rpmsg_core.c. I believe this is with -M, but as I only extracted part of the file it did not detect it as a rename. I will see if I can figure something out for v2. Perhaps if I split the move in more than one commit it will be easier to follow; like take the device management in one chunk and the rpmsg_send() functions in one would reduce the size of the two patches quite a bit. > > > 5 files changed, 569 insertions(+), 473 deletions(-) > > create mode 100644 drivers/rpmsg/rpmsg_core.c > > create mode 100644 drivers/rpmsg/rpmsg_internal.h > > > > diff --git a/drivers/rpmsg/Kconfig b/drivers/rpmsg/Kconfig > > index 69a219387582..40614be88c97 100644 > > --- a/drivers/rpmsg/Kconfig > > +++ b/drivers/rpmsg/Kconfig > > @@ -3,6 +3,10 @@ menu "Rpmsg drivers" > > # RPMSG always gets selected by whoever wants it > > config RPMSG > > tristate > > + > > +config RPMSG_VIRTIO > > + tristate > > + select RPMSG > > select VIRTIO > > select VIRTUALIZATION > > > Remoteproc Kconfig should be changed too to select RPMSG_VIRTIO instead of RPMSG. > You're right, forgot to include that. I still think this should be a user selectable option, rather than being tied to particular remoteproc drivers - but let's take that discussion separately. Thanks, Bjorn
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH 00/14] Split rpmsg into a framework Bjorn Andersson <bjorn.andersson@linaro.org> - 2016-08-16 02:20 +0200
[PATCH 12/14] rpmsg: Make rpmsg_create_ept() take channel_info struct Bjorn Andersson <bjorn.andersson@linaro.org> - 2016-08-16 02:20 +0200
[PATCH 04/14] rpmsg: Internalize rpmsg_send() implementations Bjorn Andersson <bjorn.andersson@linaro.org> - 2016-08-16 02:20 +0200
[PATCH 13/14] rpmsg: Allow callback to return errors Bjorn Andersson <bjorn.andersson@linaro.org> - 2016-08-16 02:20 +0200
[PATCH 09/14] rpmsg: Internalize rpmsg core ops Bjorn Andersson <bjorn.andersson@linaro.org> - 2016-08-16 02:20 +0200
[PATCH 02/14] rpmsg: Name rpmsg devices based on channel id Bjorn Andersson <bjorn.andersson@linaro.org> - 2016-08-16 02:20 +0200
[PATCH 11/14] rpmsg: Move virtio specifics from public header Bjorn Andersson <bjorn.andersson@linaro.org> - 2016-08-16 02:20 +0200
[PATCH 05/14] rpmsg: Unify rpmsg device vs channel naming Bjorn Andersson <bjorn.andersson@linaro.org> - 2016-08-16 02:20 +0200
[PATCH 03/14] rpmsg: rpmsg_send() operations takes rpmsg_endpoint Bjorn Andersson <bjorn.andersson@linaro.org> - 2016-08-16 02:30 +0200
RE: [PATCH 03/14] rpmsg: rpmsg_send() operations takes rpmsg_endpoint Loic PALLARDY <loic.pallardy@st.com> - 2016-08-18 09:40 +0200
Re: [PATCH 03/14] rpmsg: rpmsg_send() operations takes rpmsg_endpoint Bjorn Andersson <bjorn.andersson@linaro.org> - 2016-08-19 03:00 +0200
[PATCH 01/14] rpmsg: Enable matching devices with drivers based on DT Bjorn Andersson <bjorn.andersson@linaro.org> - 2016-08-16 02:30 +0200
Re: [PATCH 08/14] rpmsg: Split rpmsg core and virtio backend Bjorn Andersson <bjorn.andersson@linaro.org> - 2016-08-19 03:30 +0200
csiph-web