Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1460735
| From | Bjorn Andersson <bjorn.andersson@linaro.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 2/2] remoteproc: core: Rework obtaining a rproc from a DT phandle |
| Date | 2016-08-11 20:50 +0200 |
| Message-ID | <s53df-7wo-15@gated-at.bofh.it> (permalink) |
| References | <rWFB8-5U4-29@gated-at.bofh.it> <rWFB8-5U4-27@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Tue 19 Jul 08:49 PDT 2016, Lee Jones wrote:
> diff --git a/drivers/remoteproc/remoteproc_core.c b/drivers/remoteproc/remoteproc_core.c
[..]
> -struct rproc *rproc_get_by_phandle(phandle phandle)
> +struct rproc *of_get_rproc_by_phandle(struct device_node *np)
> {
> - return NULL;
> + return of_get_rproc_by_index(np, 0);
I agree with Suman, that this should be moved to the static inline
function in remoteproc.h
Giving it some more thought, based on the naming discussion, I think
this should be called "of_get_rproc()". Better keep the "default
accessor" short and simple and the _by_phandle() is confusing.
> }
> +EXPORT_SYMBOL(of_get_rproc_by_phandle);
> #endif
> -EXPORT_SYMBOL(rproc_get_by_phandle);
[..]
> diff --git a/include/linux/remoteproc.h b/include/linux/remoteproc.h
[..]
> static inline
> -struct rproc *rproc_get_by_phandle(phandle phandle)
> +struct rproc *of_get_rproc_by_phandle(struct device_node *np)
> {
> return NULL;
> }
Regards,
Bjorn
Back to linux.kernel | Previous | Next | Find similar | Unroll thread
Re: [PATCH 2/2] remoteproc: core: Rework obtaining a rproc from a DT phandle Bjorn Andersson <bjorn.andersson@linaro.org> - 2016-08-11 20:50 +0200
csiph-web