Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1460732
| From | Bjorn Andersson <bjorn.andersson@linaro.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 1/2] remoteproc: core: Add rproc OF look-up functions |
| Date | 2016-08-11 20:30 +0200 |
| Message-ID | <s52TT-7pv-15@gated-at.bofh.it> (permalink) |
| References | (2 earlier) <s4Hw6-YV-5@gated-at.bofh.it> <s4IBR-1DK-57@gated-at.bofh.it> <s4IVc-204-27@gated-at.bofh.it> <s4Jez-29X-43@gated-at.bofh.it> <s4KtY-2Qc-11@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Wed 10 Aug 15:44 PDT 2016, Suman Anna wrote: > On 08/10/2016 04:19 PM, Bjorn Andersson wrote: > > On Wed 10 Aug 14:04 PDT 2016, Suman Anna wrote: > > [..] > > As far as cleaning up wkup_m3_ipc, patch 2 does that and cleans out the > > old implementation and with that wkup_m3_ipc is moved to the new API. > > > > So the only issue is that the wkup_m3_ipc DT binding states that the > > property should be named "ti,rproc" and as such someone has to send a > > patch to that and make an argument that we don't have to maintain > > backwards compatibility. But as this is used in am33xx.dtsi and > > am4372.dtsi that might be too late? > > I could fix up the wkup_m3_ipc driver using of_update_property() / > of_remove_property(), but looks like these are not exported. I am not > sure if there are any specific reasons as to why these were not > exported. So, for now, we may have to go with the current code. > Sorry I didn't think that far, that would be the preferred solution. Regards, Bjorn
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
Re: [PATCH 1/2] remoteproc: core: Add rproc OF look-up functions Suman Anna <s-anna@ti.com> - 2016-08-11 00:50 +0200
Re: [PATCH 1/2] remoteproc: core: Add rproc OF look-up functions Lee Jones <lee.jones@linaro.org> - 2016-08-11 09:40 +0200
Re: [PATCH 1/2] remoteproc: core: Add rproc OF look-up functions Suman Anna <s-anna@ti.com> - 2016-08-11 18:10 +0200
Re: [PATCH 1/2] remoteproc: core: Add rproc OF look-up functions Suman Anna <s-anna@ti.com> - 2016-08-11 18:30 +0200
Re: [PATCH 1/2] remoteproc: core: Add rproc OF look-up functions Suman Anna <s-anna@ti.com> - 2016-08-12 18:40 +0200
Re: [PATCH 1/2] remoteproc: core: Add rproc OF look-up functions Bjorn Andersson <bjorn.andersson@linaro.org> - 2016-08-12 20:10 +0200
Re: [PATCH 1/2] remoteproc: core: Add rproc OF look-up functions Suman Anna <s-anna@ti.com> - 2016-08-12 20:50 +0200
Re: [PATCH 1/2] remoteproc: core: Add rproc OF look-up functions Lee Jones <lee.jones@linaro.org> - 2016-08-15 16:00 +0200
Re: [PATCH 1/2] remoteproc: core: Add rproc OF look-up functions Bjorn Andersson <bjorn.andersson@linaro.org> - 2016-08-11 20:30 +0200
csiph-web