Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1457654

[PATCH v5 06/14] of_numa: Use of_get_next_parent to simplify code

From Zhen Lei <thunder.leizhen@huawei.com>
Newsgroups linux.kernel
Subject [PATCH v5 06/14] of_numa: Use of_get_next_parent to simplify code
Date 2016-08-08 11:30 +0200
Message-ID <s3P2G-7YV-43@gated-at.bofh.it> (permalink)
References <s3P2F-7YV-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


From: Kefeng Wang <wangkefeng.wang@huawei.com>

Use of_get_next_parent() instead of open-code.

Signed-off-by: Kefeng Wang <wangkefeng.wang@huawei.com>
Acked-by: Rob Herring <robh@kernel.org>
---
 drivers/of/of_numa.c | 6 +-----
 1 file changed, 1 insertion(+), 5 deletions(-)

diff --git a/drivers/of/of_numa.c b/drivers/of/of_numa.c
index 3157130..ed7bd22 100644
--- a/drivers/of/of_numa.c
+++ b/drivers/of/of_numa.c
@@ -153,8 +153,6 @@ int of_node_to_nid(struct device_node *device)
 	np = of_node_get(device);

 	while (np) {
-		struct device_node *parent;
-
 		r = of_property_read_u32(np, "numa-node-id", &nid);
 		/*
 		 * -EINVAL indicates the property was not found, and
@@ -165,9 +163,7 @@ int of_node_to_nid(struct device_node *device)
 		if (r != -EINVAL)
 			break;

-		parent = of_get_parent(np);
-		of_node_put(np);
-		np = parent;
+		np = of_get_next_parent(np);
 	}
 	if (np && r)
 		pr_warn("NUMA: Invalid \"numa-node-id\" property in node %s\n",
--
2.5.0

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v5 00/14] fix some type infos and bugs for arm64/of numa Zhen Lei <thunder.leizhen@huawei.com> - 2016-08-08 11:30 +0200
  [PATCH v5 14/14] Documentation: remove the constraint on the distances of node pairs Zhen Lei <thunder.leizhen@huawei.com> - 2016-08-08 11:30 +0200
  [PATCH v5 01/14] of/numa: remove a duplicated pr_debug information Zhen Lei <thunder.leizhen@huawei.com> - 2016-08-08 11:30 +0200
  [PATCH v5 12/14] arm64/numa: remove some useless code Zhen Lei <thunder.leizhen@huawei.com> - 2016-08-08 11:30 +0200
  [PATCH v5 06/14] of_numa: Use of_get_next_parent to simplify code Zhen Lei <thunder.leizhen@huawei.com> - 2016-08-08 11:30 +0200
  [PATCH v5 10/14] arm64/numa: define numa_distance as array to simplify code Zhen Lei <thunder.leizhen@huawei.com> - 2016-08-08 11:30 +0200
  Re: [PATCH v5 00/14] fix some type infos and bugs for arm64/of numa Hanjun Guo <guohanjun@huawei.com> - 2016-08-10 04:10 +0200

csiph-web