Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1457164
| From | Sebastian Andrzej Siewior <bigeasy@linutronix.de> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [RFC][PATCH 1/3] tracing: Added hardware latency tracer |
| Date | 2016-08-05 17:30 +0200 |
| Message-ID | <s2Peq-PT-17@gated-at.bofh.it> (permalink) |
| References | <s2srw-2sp-9@gated-at.bofh.it> <s2srw-2sp-23@gated-at.bofh.it> <s2Oil-eE-7@gated-at.bofh.it> <s2OBH-lD-13@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 08/05/2016 04:44 PM, Steven Rostedt wrote: > On Fri, 5 Aug 2016 16:25:21 +0200 > Sebastian Andrzej Siewior <bigeasy@linutronix.de> wrote: > >> * Steven Rostedt | 2016-08-04 10:57:09 [-0400]: >> >>> diff --git a/kernel/trace/trace_hwlat.c b/kernel/trace/trace_hwlat.c >>> new file mode 100644 >>> index 000000000000..08dfabe4e862 >>> --- /dev/null >>> +++ b/kernel/trace/trace_hwlat.c >> … >>> +/* Macros to encapsulate the time capturing infrastructure */ >>> +#define time_type u64 >>> +#define time_get() trace_clock_local() >>> +#define time_to_us(x) div_u64(x, 1000) >>> +#define time_sub(a, b) ((a) - (b)) >>> +#define init_time(a, b) (a = b) >>> +#define time_u64(a) a >> >> Do we need a macro for this? In the old code we could choose between >> CONFIG_TRACING but now we don't. >> > > Probably not, I kept it for two reasons. 1) to keep the same logic as > what was in PREEMPT_RT, and 2) in case we can come up with a better > clock. I assumed it was a leftover. > But it's not that important. Should it be nuked? They do somewhat make > the code easier to read. that time_get() is close to ktime_get() which is almost u64 nowadays. So it might not be that cool for upstream. A hwlat prefix makes the whole thing not prettier. 1. PREEMPT_RT. Do I need any changes? I assumed I could keep this 1:1 (once it is merged) and throw the current hwlat out. 2. a better clock is an argument. But why would you have a better clock for hwlat and not for the whole tracing infrastructure? If you want to keep it, keep it. I just assumed it was a leftover. > > -- Steve Sebastian
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[RFC][PATCH 0/3] tracing: Add Hardware Latency detector tracer Steven Rostedt <rostedt@goodmis.org> - 2016-08-04 17:10 +0200
[RFC][PATCH 3/3] tracing: Have hwlat trace migrate across tracing_cpumask CPUs Steven Rostedt <rostedt@goodmis.org> - 2016-08-04 17:10 +0200
[RFC][PATCH 1/3] tracing: Added hardware latency tracer Steven Rostedt <rostedt@goodmis.org> - 2016-08-04 17:10 +0200
Re: [RFC][PATCH 1/3] tracing: Added hardware latency tracer Sebastian Andrzej Siewior <bigeasy@linutronix.de> - 2016-08-05 16:30 +0200
Re: [RFC][PATCH 1/3] tracing: Added hardware latency tracer Steven Rostedt <rostedt@goodmis.org> - 2016-08-05 16:50 +0200
Re: [RFC][PATCH 1/3] tracing: Added hardware latency tracer Sebastian Andrzej Siewior <bigeasy@linutronix.de> - 2016-08-05 17:30 +0200
Re: [RFC][PATCH 1/3] tracing: Added hardware latency tracer Steven Rostedt <rostedt@goodmis.org> - 2016-08-05 17:40 +0200
[RFC][PATCH 2/3] tracing: Add documentation for hwlat_detector tracer Steven Rostedt <rostedt@goodmis.org> - 2016-08-04 17:10 +0200
Re: [RFC][PATCH 2/3] tracing: Add documentation for hwlat_detector tracer Jon Masters <jcm@redhat.com> - 2016-08-10 21:30 +0200
Re: [RFC][PATCH 0/3] tracing: Add Hardware Latency detector tracer Steven Rostedt <rostedt@goodmis.org> - 2016-08-04 17:40 +0200
Re: [RFC][PATCH 0/3] tracing: Add Hardware Latency detector tracer Clark Williams <williams@redhat.com> - 2016-08-09 20:20 +0200
Re: [RFC][PATCH 0/3] tracing: Add Hardware Latency detector tracer Steven Rostedt <rostedt@goodmis.org> - 2016-08-09 20:40 +0200
[RFC][PATCH 4/3] tracing: Add NMI tracing in hwlat detector Steven Rostedt <rostedt@goodmis.org> - 2016-08-04 19:00 +0200
Re: [RFC][PATCH 4/3] tracing: Add NMI tracing in hwlat detector Steven Rostedt <rostedt@goodmis.org> - 2016-08-04 19:20 +0200
Re: [RFC][PATCH 4/3] tracing: Add NMI tracing in hwlat detector Sebastian Andrzej Siewior <bigeasy@linutronix.de> - 2016-08-05 16:40 +0200
Re: [RFC][PATCH 4/3] tracing: Add NMI tracing in hwlat detector Steven Rostedt <rostedt@goodmis.org> - 2016-08-05 17:00 +0200
Re: [RFC][PATCH 4/3] tracing: Add NMI tracing in hwlat detector Sebastian Andrzej Siewior <bigeasy@linutronix.de> - 2016-08-05 17:50 +0200
Re: [RFC][PATCH 4/3] tracing: Add NMI tracing in hwlat detector Steven Rostedt <rostedt@goodmis.org> - 2016-08-05 18:20 +0200
Re: [RFC][PATCH 4/3] tracing: Add NMI tracing in hwlat detector Steven Rostedt <rostedt@goodmis.org> - 2016-08-09 19:30 +0200
Re: [RFC][PATCH 4/3] tracing: Add NMI tracing in hwlat detector Jon Masters <jcm@redhat.com> - 2016-08-10 21:00 +0200
[RFC][PATCH 5/3] tracing: Add smi counting to HWLAT Steven Rostedt <rostedt@goodmis.org> - 2016-08-09 20:10 +0200
Re: [RFC][PATCH 5/3] tracing: Add smi counting to HWLAT Daniel Bristot de Oliveira <bristot@redhat.com> - 2016-08-09 20:30 +0200
Re: [RFC][PATCH 5/3] tracing: Add smi counting to HWLAT Steven Rostedt <rostedt@goodmis.org> - 2016-08-09 20:40 +0200
Re: [RFC][PATCH 5/3] tracing: Add smi counting to HWLAT Peter Zijlstra <peterz@infradead.org> - 2016-08-09 23:30 +0200
csiph-web