Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1457199
| From | Josh Poimboeuf <jpoimboe@redhat.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v2 03/44] x86/asm/head: rename 'stack_start' -> 'initial_stack' |
| Date | 2016-08-05 18:10 +0200 |
| Message-ID | <s2PR8-1kZ-11@gated-at.bofh.it> (permalink) |
| References | <s2zjj-7xL-9@gated-at.bofh.it> <s2zt0-7Bf-35@gated-at.bofh.it> <s2Pep-PT-11@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Fri, Aug 05, 2016 at 10:28:39AM -0500, Nilay Vaish wrote:
> On 4 August 2016 at 17:21, Josh Poimboeuf <jpoimboe@redhat.com> wrote:
> > The 'stack_start' variable is similar in usage to 'initial_code' and
> > 'initial_gs': they're all stored in head_64.S and they're all updated by
> > SMP and ACPI suspend before starting a CPU.
> >
> > Rename it to 'initial_stack' to be consistent with the others.
> >
>
> May be change the following line as well:
>
> ./arch/x86/kernel/head_64.S:69: * Setup stack for verify_cpu().
> "-8" because stack_start is defined
Ah, yeah, I missed that one.
And also, now that I see that comment, and the line below it:
leaq (__end_init_task - 8)(%rip), %rsp
The 8 should be changed to SIZEOF_PTREGS in a later patch
("x86/asm/head: standardize the end of the stack for idle tasks").
--
Josh
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v2 00/44] x86/dumpstack: rewrite x86 stack dump code Josh Poimboeuf <jpoimboe@redhat.com> - 2016-08-05 00:40 +0200
[PATCH v2 07/44] x86/dumpstack: remove extra brackets around "<EOE>" Josh Poimboeuf <jpoimboe@redhat.com> - 2016-08-05 00:40 +0200
[PATCH v2 11/44] x86/dumpstack: remove unnecessary stack pointer arguments Josh Poimboeuf <jpoimboe@redhat.com> - 2016-08-05 00:40 +0200
[PATCH v2 06/44] x86/dumpstack: add IRQ_USABLE_STACK_SIZE define Josh Poimboeuf <jpoimboe@redhat.com> - 2016-08-05 00:40 +0200
[PATCH v2 14/44] x86/asm/head: put real return address on idle task stack Josh Poimboeuf <jpoimboe@redhat.com> - 2016-08-05 00:40 +0200
[PATCH v2 02/44] x86/asm/head: remove unused init_rsp variable Josh Poimboeuf <jpoimboe@redhat.com> - 2016-08-05 00:40 +0200
[PATCH v2 18/44] ftrace: remove CONFIG_HAVE_FUNCTION_GRAPH_FP_TEST from config Josh Poimboeuf <jpoimboe@redhat.com> - 2016-08-05 00:40 +0200
[PATCH v2 17/44] proc: fix return address printk conversion specifer in /proc/<pid>/stack Josh Poimboeuf <jpoimboe@redhat.com> - 2016-08-05 00:40 +0200
[PATCH v2 20/44] ftrace: add return address pointer to ftrace_ret_stack Josh Poimboeuf <jpoimboe@redhat.com> - 2016-08-05 00:40 +0200
[PATCH v2 15/44] perf/x86: check perf_callchain_store() error Josh Poimboeuf <jpoimboe@redhat.com> - 2016-08-05 00:40 +0200
[PATCH v2 04/44] x86/asm/head: use a common function for starting CPUs Josh Poimboeuf <jpoimboe@redhat.com> - 2016-08-05 00:40 +0200
Re: [PATCH v2 04/44] x86/asm/head: use a common function for starting CPUs Nilay Vaish <nilayvaish@gmail.com> - 2016-08-05 17:50 +0200
Re: [PATCH v2 04/44] x86/asm/head: use a common function for starting CPUs Josh Poimboeuf <jpoimboe@redhat.com> - 2016-08-05 18:20 +0200
[PATCH v2 03/44] x86/asm/head: rename 'stack_start' -> 'initial_stack' Josh Poimboeuf <jpoimboe@redhat.com> - 2016-08-05 00:40 +0200
Re: [PATCH v2 03/44] x86/asm/head: rename 'stack_start' -> 'initial_stack' Nilay Vaish <nilayvaish@gmail.com> - 2016-08-05 17:30 +0200
Re: [PATCH v2 03/44] x86/asm/head: rename 'stack_start' -> 'initial_stack' Josh Poimboeuf <jpoimboe@redhat.com> - 2016-08-05 18:10 +0200
Re: [PATCH v2 03/44] x86/asm/head: rename 'stack_start' -> 'initial_stack' Josh Poimboeuf <jpoimboe@redhat.com> - 2016-08-06 22:30 +0200
Re: [PATCH v2 03/44] x86/asm/head: rename 'stack_start' -> 'initial_stack' Borislav Petkov <bp@alien8.de> - 2016-08-06 22:50 +0200
Re: [PATCH v2 03/44] x86/asm/head: rename 'stack_start' -> 'initial_stack' Josh Poimboeuf <jpoimboe@redhat.com> - 2016-08-06 22:50 +0200
Re: [PATCH v2 03/44] x86/asm/head: rename 'stack_start' -> 'initial_stack' Brian Gerst <brgerst@gmail.com> - 2016-08-07 00:30 +0200
[PATCH v2 09/44] x86/dumpstack: fix x86_32 kernel_stack_pointer() previous stack access Josh Poimboeuf <jpoimboe@redhat.com> - 2016-08-05 00:40 +0200
[PATCH v2 22/44] x86/dumpstack/ftrace: convert dump_trace() callbacks to use ftrace_graph_ret_addr() Josh Poimboeuf <jpoimboe@redhat.com> - 2016-08-05 00:40 +0200
[PATCH v2 12/44] x86: move _stext marker to before head code Josh Poimboeuf <jpoimboe@redhat.com> - 2016-08-05 00:40 +0200
csiph-web