Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1457156
| From | Juri Lelli <juri.lelli@arm.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v5] sched/deadline: remove useless param from setup_new_dl_entity |
| Date | 2016-08-05 17:10 +0200 |
| Message-ID | <s2OV3-I9-5@gated-at.bofh.it> (permalink) |
| References | <s2Kop-69A-1@gated-at.bofh.it> <s2NPk-8h7-21@gated-at.bofh.it> <s2Os2-i5-11@gated-at.bofh.it> <s2OLo-ph-19@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 05/08/16 10:54, Steven Rostedt wrote:
> On Fri, 5 Aug 2016 15:34:44 +0100
> Juri Lelli <juri.lelli@arm.com> wrote:
>
> > On 05/08/16 09:56, Steven Rostedt wrote:
> > > On Fri, 5 Aug 2016 11:09:59 +0100
> > > Juri Lelli <juri.lelli@arm.com> wrote:
> > >
> > > > @@ -1720,19 +1720,28 @@ static void switched_from_dl(struct rq *rq, struct task_struct *p)
> > > > */
> > > > static void switched_to_dl(struct rq *rq, struct task_struct *p)
> > > > {
> > > > - if (dl_time_before(p->dl.deadline, rq_clock(rq)))
> > > > - setup_new_dl_entity(&p->dl, &p->dl);
> > > >
> > > > - if (task_on_rq_queued(p) && rq->curr != p) {
> > > > + if (task_on_rq_queued(p)) {
> > >
> > > I always hated functions totally encapsulated by an if statement. This
> > > can be a bit simpler (and less indented) if you have:
> > >
> > > /* If p is not queued, its parameters will be updated at wakeup */
> > > if (!task_on_rq_queued(p))
> > > return;
> > >
> > > [...]
> > >
> >
> > You mean like what follows?
> >
> > I'll post a v6 if OK.
> >
>
> Yes! I think that looks much nicer, and easier to read.
>
Yep. Way better. :)
> You can add my Reviewed-by tag too.
>
Thanks!
Best,
- Juri
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH v5] sched/deadline: remove useless param from setup_new_dl_entity Juri Lelli <juri.lelli@arm.com> - 2016-08-05 12:20 +0200
Re: [PATCH v5] sched/deadline: remove useless param from setup_new_dl_entity Xunlei Pang <xpang@redhat.com> - 2016-08-05 14:50 +0200
Re: [PATCH v5] sched/deadline: remove useless param from setup_new_dl_entity Steven Rostedt <rostedt@goodmis.org> - 2016-08-05 16:00 +0200
Re: [PATCH v5] sched/deadline: remove useless param from setup_new_dl_entity Juri Lelli <juri.lelli@arm.com> - 2016-08-05 16:40 +0200
Re: [PATCH v5] sched/deadline: remove useless param from setup_new_dl_entity Steven Rostedt <rostedt@goodmis.org> - 2016-08-05 17:00 +0200
Re: [PATCH v5] sched/deadline: remove useless param from setup_new_dl_entity Juri Lelli <juri.lelli@arm.com> - 2016-08-05 17:10 +0200
csiph-web