Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1455882
| From | Krzysztof Kozlowski <k.kozlowski@samsung.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 0210/1285] Replace numeric parameter like 0444 with macro |
| Date | 2016-08-03 18:20 +0200 |
| Message-ID | <s273H-4KR-9@gated-at.bofh.it> (permalink) |
| References | <s1MBX-8c3-1@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Tue, Aug 02, 2016 at 06:50:01PM +0800, Baole Ni wrote: > I find that the developers often just specified the numeric value > when calling a macro which is defined with a parameter for access permission. > As we know, these numeric value for access permission have had the corresponding macro, > and that using macro can improve the robustness and readability of the code, > thus, I suggest replacing the numeric parameter with the macro. > > Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com> > Signed-off-by: Baole Ni <baolex.ni@intel.com> > --- > drivers/gpu/drm/qxl/qxl_drv.c | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) I got almost 1000 patches out of your mail bomb. For all of them: NACK. Other people pointed actual reasons (title, readability, cc-list). The commit msg should be also written in a more readable way. Anyway, in Intel there are a lot of people having kernel contributions so it is a shame that you didn't ask them for advice how to do it... BR, Krzysztof
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH 0210/1285] Replace numeric parameter like 0444 with macro Baole Ni <baolex.ni@intel.com> - 2016-08-02 20:30 +0200 Re: [PATCH 0210/1285] Replace numeric parameter like 0444 with macro Krzysztof Kozlowski <k.kozlowski@samsung.com> - 2016-08-03 18:20 +0200
csiph-web