Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1455407

Re: [PATCH 1116/1285] Replace numeric parameter like 0444 with macro

From Jan Engelhardt <jengelh@inai.de>
Newsgroups linux.kernel
Subject Re: [PATCH 1116/1285] Replace numeric parameter like 0444 with macro
Date 2016-08-02 21:10 +0200
Message-ID <s1NeG-gB-41@gated-at.bofh.it> (permalink)
References <s1II2-5y4-25@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Tuesday 2016-08-02 14:17, Baole Ni wrote:

>I find that the developers often just specified the numeric value
>when calling a macro which is defined with a parameter for access permission.
>As we know, these numeric value for access permission have had the corresponding macro,
>and that using macro can improve the robustness and readability of the code,
>thus, I suggest replacing the numeric parameter with the macro.
>
> static int ip_vs_conn_tab_bits = CONFIG_IP_VS_TAB_BITS;
>-module_param_named(conn_tab_bits, ip_vs_conn_tab_bits, int, 0444);
>+module_param_named(conn_tab_bits, ip_vs_conn_tab_bits, int, S_IRUSR | S_IRGRP | S_IROTH);

We have S_IRUGO for this.

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 1116/1285] Replace numeric parameter like 0444 with macro Baole Ni <baolex.ni@intel.com> - 2016-08-02 16:20 +0200
  Re: [PATCH 1116/1285] Replace numeric parameter like 0444 with  macro Jan Engelhardt <jengelh@inai.de> - 2016-08-02 21:10 +0200
    Re: [PATCH 1116/1285] Replace numeric parameter like 0444 with macro Jarod Wilson <jarod@redhat.com> - 2016-08-02 21:50 +0200

csiph-web