Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1454503

[PATCH 1274/1285] Replace numeric parameter like 0444 with macro

From Baole Ni <baolex.ni@intel.com>
Newsgroups linux.kernel
Subject [PATCH 1274/1285] Replace numeric parameter like 0444 with macro
Date 2016-08-02 16:10 +0200
Message-ID <s1Iyn-5ut-75@gated-at.bofh.it> (permalink)
Organization linux.* mail to news gateway

Show all headers | View raw


I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.

Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
Signed-off-by: Baole Ni <baolex.ni@intel.com>
---
 sound/sound_core.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/sound/sound_core.c b/sound/sound_core.c
index 99b73c6..2c3c09c 100644
--- a/sound/sound_core.c
+++ b/sound/sound_core.c
@@ -154,7 +154,7 @@ static int preclaim_oss = 1;
 static int preclaim_oss = 0;
 #endif
 
-module_param(preclaim_oss, int, 0444);
+module_param(preclaim_oss, int, S_IRUSR | S_IRGRP | S_IROTH);
 
 static int soundcore_open(struct inode *, struct file *);
 
-- 
2.9.2

Back to linux.kernel | Previous | Next | Find similar | Unroll thread


Thread

[PATCH 1274/1285] Replace numeric parameter like 0444 with macro Baole Ni <baolex.ni@intel.com> - 2016-08-02 16:10 +0200

csiph-web