Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1454541

[PATCH 1079/1285] Replace numeric parameter like 0444 with macro

From Baole Ni <baolex.ni@intel.com>
Newsgroups linux.kernel
Subject [PATCH 1079/1285] Replace numeric parameter like 0444 with macro
Date 2016-08-02 16:30 +0200
Message-ID <s1HVE-50V-39@gated-at.bofh.it> (permalink)
Organization linux.* mail to news gateway

Show all headers | View raw


I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.

Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
Signed-off-by: Baole Ni <baolex.ni@intel.com>
---
 lib/842/842_compress.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/lib/842/842_compress.c b/lib/842/842_compress.c
index 4051339..bf45ea3 100644
--- a/lib/842/842_compress.c
+++ b/lib/842/842_compress.c
@@ -42,7 +42,7 @@
  * so that any length buffer can be compressed.
  */
 static bool sw842_strict;
-module_param_named(strict, sw842_strict, bool, 0644);
+module_param_named(strict, sw842_strict, bool, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
 
 static u8 comp_ops[OPS_MAX][5] = { /* params size in bits */
 	{ I8, N0, N0, N0, 0x19 }, /* 8 */
-- 
2.9.2

Back to linux.kernel | Previous | Next | Find similar | Unroll thread


Thread

[PATCH 1079/1285] Replace numeric parameter like 0444 with macro Baole Ni <baolex.ni@intel.com> - 2016-08-02 16:30 +0200

csiph-web