Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1453869
| From | Baole Ni <baolex.ni@intel.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 0236/1285] Replace numeric parameter like 0444 with macro |
| Date | 2016-08-02 13:40 +0200 |
| Message-ID | <s1Gde-3Oh-95@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.
Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
Signed-off-by: Baole Ni <baolex.ni@intel.com>
---
drivers/hwmon/acpi_power_meter.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/hwmon/acpi_power_meter.c b/drivers/hwmon/acpi_power_meter.c
index 579bdf9..11460f7 100644
--- a/drivers/hwmon/acpi_power_meter.c
+++ b/drivers/hwmon/acpi_power_meter.c
@@ -1008,7 +1008,7 @@ MODULE_AUTHOR("Darrick J. Wong <darrick.wong@oracle.com>");
MODULE_DESCRIPTION("ACPI 4.0 power meter driver");
MODULE_LICENSE("GPL");
-module_param(force_cap_on, bool, 0644);
+module_param(force_cap_on, bool, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
MODULE_PARM_DESC(force_cap_on, "Enable power cap even it is unsafe to do so.");
module_init(acpi_power_meter_init);
--
2.9.2
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
[PATCH 0236/1285] Replace numeric parameter like 0444 with macro Baole Ni <baolex.ni@intel.com> - 2016-08-02 13:40 +0200 Re: [PATCH 0236/1285] Replace numeric parameter like 0444 with macro Jean Delvare <jdelvare@suse.de> - 2016-08-02 22:30 +0200
csiph-web