Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1453867

[PATCH 0142/1285] Replace numeric parameter like 0444 with macro

Path csiph.com!news.mixmin.net!aioe.org!bofh.it!news.nic.it!robomod
From Baole Ni <baolex.ni@intel.com>
Newsgroups linux.kernel
Subject [PATCH 0142/1285] Replace numeric parameter like 0444 with macro
Date Tue, 02 Aug 2016 13:40:04 +0200
Message-ID <s1Gde-3Oh-91@gated-at.bofh.it> (permalink)
X-Original-To mchehab@kernel.org, maurochehab@gmail.com, mchehab@infradead.org, mchehab@redhat.com, m.chehab@samsung.com, dougthompson@xmission.com, bp@alien8.de
X-Extloop1 1
X-Ironport-Av E=Sophos;i="5.28,459,1464678000"; d="scan'208";a="1033566238"
X-Mailer git-send-email 2.9.2
Sender robomod@news.nic.it
List-ID <linux-kernel.vger.kernel.org>
X-Mailing-List linux-kernel@vger.kernel.org
Approved robomod@news.nic.it
Lines 39
Organization linux.* mail to news gateway
X-Original-Cc linux-edac@vger.kernel.org, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com, lee.jones@linaro.org
X-Original-Date Tue, 2 Aug 2016 18:44:05 +0800
X-Original-Message-ID <20160802104405.23214-1-baolex.ni@intel.com>
X-Original-Sender linux-kernel-owner@vger.kernel.org
Xref csiph.com linux.kernel:1453867

Show key headers only | View raw


I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.

Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
Signed-off-by: Baole Ni <baolex.ni@intel.com>
---
 drivers/edac/edac_mc_sysfs.c | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/drivers/edac/edac_mc_sysfs.c b/drivers/edac/edac_mc_sysfs.c
index 10c305b..1603b76 100644
--- a/drivers/edac/edac_mc_sysfs.c
+++ b/drivers/edac/edac_mc_sysfs.c
@@ -74,16 +74,16 @@ static int edac_set_poll_msec(const char *val, struct kernel_param *kp)
 }
 
 /* Parameter declarations for above */
-module_param(edac_mc_panic_on_ue, int, 0644);
+module_param(edac_mc_panic_on_ue, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(edac_mc_panic_on_ue, "Panic on uncorrected error: 0=off 1=on");
-module_param(edac_mc_log_ue, int, 0644);
+module_param(edac_mc_log_ue, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(edac_mc_log_ue,
 		 "Log uncorrectable error to console: 0=off 1=on");
-module_param(edac_mc_log_ce, int, 0644);
+module_param(edac_mc_log_ce, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(edac_mc_log_ce,
 		 "Log correctable error to console: 0=off 1=on");
 module_param_call(edac_mc_poll_msec, edac_set_poll_msec, param_get_int,
-		  &edac_mc_poll_msec, 0644);
+		  &edac_mc_poll_msec, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(edac_mc_poll_msec, "Polling period in milliseconds");
 
 static struct device *mci_pdev;
-- 
2.9.2

Back to linux.kernel | Previous | Next | Find similar | Unroll thread


Thread

[PATCH 0142/1285] Replace numeric parameter like 0444 with macro Baole Ni <baolex.ni@intel.com> - 2016-08-02 13:40 +0200

csiph-web