Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1453768
| From | Baole Ni <baolex.ni@intel.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 0066/1285] Replace numeric parameter like 0444 with macro |
| Date | 2016-08-02 13:20 +0200 |
| Message-ID | <s1FTR-3Ey-63@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com> Signed-off-by: Baole Ni <baolex.ni@intel.com> --- drivers/ata/sata_sil.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/ata/sata_sil.c b/drivers/ata/sata_sil.c index 29bcff0..5e35bfb 100644 --- a/drivers/ata/sata_sil.c +++ b/drivers/ata/sata_sil.c @@ -260,7 +260,7 @@ MODULE_DEVICE_TABLE(pci, sil_pci_tbl); MODULE_VERSION(DRV_VERSION); static int slow_down; -module_param(slow_down, int, 0444); +module_param(slow_down, int, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(slow_down, "Sledgehammer used to work around random problems, by limiting commands to 15 sectors (0=off, 1=on)"); -- 2.9.2
Back to linux.kernel | Previous | Next | Find similar | Unroll thread
[PATCH 0066/1285] Replace numeric parameter like 0444 with macro Baole Ni <baolex.ni@intel.com> - 2016-08-02 13:20 +0200
csiph-web