Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1401626

[PATCH v2 0/5] of: dynamic: Changesets helpers & fixes

From Pantelis Antoniou <pantelis.antoniou@konsulko.com>
Newsgroups linux.kernel
Subject [PATCH v2 0/5] of: dynamic: Changesets helpers & fixes
Date 2016-05-16 18:50 +0200
Message-ID <rztSq-10v-13@gated-at.bofh.it> (permalink)
Organization linux.* mail to news gateway

Show all headers | View raw


This patchset introduces changeset helpers which makes working with
changeset much easier and less error prone.

The first patch exports an internal method which is used for the third patch
which contains the bulk of the changes.

The second introduces a of_changeset_node_move method that helps when
moving subtrees.

The third contains the changesets unittests.

The final patch converts an in-kernel user to the helpers.

Finally the last patch adds a unittest for the changeset helpers.

Changes since v1:
* Dropped accepted patch
* Addressed maintainer comments
* Made a lot of methods that made sense into static inlines.
* Split out of_changeset_node_move method into a seperate patch
* Add in-kernel conversion i2c-demux patch

Pantelis Antoniou (5):
  of: dynamic: Add __of_node_dupv()
  of: changesets: Introduce changeset helper methods
  of: changeset: Add of_changeset_node_move method
  of: unittest: changeset helpers
  i2c: demux: Use changeset helpers for clarity

 drivers/i2c/muxes/i2c-demux-pinctrl.c |   5 +-
 drivers/of/dynamic.c                  | 321 +++++++++++++++++++++++++++++++-
 drivers/of/unittest.c                 |  54 ++++++
 include/linux/of.h                    | 337 ++++++++++++++++++++++++++++++++++
 4 files changed, 708 insertions(+), 9 deletions(-)

-- 
1.7.12

Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread


Thread

[PATCH v2 0/5]  of: dynamic: Changesets helpers & fixes Pantelis Antoniou <pantelis.antoniou@konsulko.com> - 2016-05-16 18:50 +0200
  [PATCH v2 3/5] of: changeset: Add of_changeset_node_move method Pantelis Antoniou <pantelis.antoniou@konsulko.com> - 2016-05-16 18:50 +0200
  [PATCH v2 2/5] of: changesets: Introduce changeset helper methods Pantelis Antoniou <pantelis.antoniou@konsulko.com> - 2016-05-16 18:50 +0200

csiph-web