Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1402579

Re: [PATCH v2 1/1] userfaultfd: don't pin the user memory in userfaultfd_file_create()

From Michal Hocko <mhocko@kernel.org>
Newsgroups linux.kernel
Subject Re: [PATCH v2 1/1] userfaultfd: don't pin the user memory in userfaultfd_file_create()
Date 2016-05-17 22:40 +0200
Message-ID <rzTWy-T4-5@gated-at.bofh.it> (permalink)
References <rzsCZ-hC-15@gated-at.bofh.it> <rzsCZ-hC-13@gated-at.bofh.it> <rzuve-1tB-25@gated-at.bofh.it> <rzPge-6lc-37@gated-at.bofh.it> <rzQci-6VD-25@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Tue 17-05-16 18:30:44, Oleg Nesterov wrote:
> On 05/17, Michal Hocko wrote:
> >
> > On Mon 16-05-16 19:22:54, Oleg Nesterov wrote:
> >
> > > The patch adds the new trivial helper, mmget_not_zero(), it can have more users.
> >
> > Is this really helpful?
> 
> Well, this is subjective of course, but I think the code looks a bit better this
> way. uprobes, fs/proc and more can use this helper too.
> 
> And in fact the initial version of this patch did atomic_inc_not_zero(mm->users) by
> hand, then it was suggested to add a helper.

I would prefer a more descriptive name (something like mmget_alive) but
as you say this is highly subjective and nothing that should delay this
fix.

-- 
Michal Hocko
SUSE Labs

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH 1/1] userfaultfd: don't pin the user memory in  userfaultfd_file_create() Oleg Nesterov <oleg@redhat.com> - 2016-05-16 17:30 +0200
  Re: [PATCH 1/1] userfaultfd: don't pin the user memory in  userfaultfd_file_create() Andrea Arcangeli <aarcange@redhat.com> - 2016-05-16 18:00 +0200
    Re: [PATCH 1/1] userfaultfd: don't pin the user memory in  userfaultfd_file_create() Oleg Nesterov <oleg@redhat.com> - 2016-05-16 18:30 +0200
  [PATCH v2 1/1] userfaultfd: don't pin the user memory in  userfaultfd_file_create() Oleg Nesterov <oleg@redhat.com> - 2016-05-16 19:30 +0200
    Re: [PATCH v2 1/1] userfaultfd: don't pin the user memory in  userfaultfd_file_create() Michal Hocko <mhocko@kernel.org> - 2016-05-17 17:40 +0200
      Re: [PATCH v2 1/1] userfaultfd: don't pin the user memory in  userfaultfd_file_create() Oleg Nesterov <oleg@redhat.com> - 2016-05-17 18:40 +0200
        Re: [PATCH v2 1/1] userfaultfd: don't pin the user memory in  userfaultfd_file_create() Michal Hocko <mhocko@kernel.org> - 2016-05-17 22:40 +0200

csiph-web