Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1400919
| From | Muhammad Falak R Wani <falakreyaz@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH v2] drm/amd/powerplay: use ARRAY_SIZE() to calculate array size. |
| Date | 2016-05-13 19:40 +0200 |
| Message-ID | <rypea-8bu-23@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
It is preferred to use ARRAY_SIZE() for size calculation, instead
using sizeof(array)/sizeof(*array). It makes the code more readable.
Signed-off-by: Muhammad Falak R Wani <falakreyaz@gmail.com>
---
drivers/gpu/drm/amd/powerplay/smumgr/cz_smumgr.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/gpu/drm/amd/powerplay/smumgr/cz_smumgr.c b/drivers/gpu/drm/amd/powerplay/smumgr/cz_smumgr.c
index da18f44..87c023e 100644
--- a/drivers/gpu/drm/amd/powerplay/smumgr/cz_smumgr.c
+++ b/drivers/gpu/drm/amd/powerplay/smumgr/cz_smumgr.c
@@ -639,7 +639,7 @@ static int cz_smu_populate_firmware_entries(struct pp_smumgr *smumgr)
cz_smu->driver_buffer_length = 0;
- for (i = 0; i < sizeof(firmware_list)/sizeof(*firmware_list); i++) {
+ for (i = 0; i < ARRAY_SIZE(firmware_list); i++) {
firmware_type = cz_translate_firmware_enum_to_arg(smumgr,
firmware_list[i]);
--
1.9.1
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
[PATCH v2] drm/amd/powerplay: use ARRAY_SIZE() to calculate array size. Muhammad Falak R Wani <falakreyaz@gmail.com> - 2016-05-13 19:40 +0200
Re: [PATCH v2] drm/amd/powerplay: use ARRAY_SIZE() to calculate array size. Eric Engestrom <eric.engestrom@imgtec.com> - 2016-05-16 18:00 +0200
Re: [PATCH v2] drm/amd/powerplay: use ARRAY_SIZE() to calculate array size. Muhammad Falak R Wani <falakreyaz@gmail.com> - 2016-05-17 08:30 +0200
Re: [PATCH v2] drm/amd/powerplay: use ARRAY_SIZE() to calculate array size. Alex Deucher <alexdeucher@gmail.com> - 2016-05-16 18:20 +0200
csiph-web