Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1398290
| From | Vinod Koul <vinod.koul@intel.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v1 2/2] dmaengine: rename cmd_pause to cmd_suspend |
| Date | 2016-05-10 18:10 +0200 |
| Message-ID | <rxiot-5TU-77@gated-at.bofh.it> (permalink) |
| References | <rvaEH-1v3-47@gated-at.bofh.it> <rvaOm-1Bc-13@gated-at.bofh.it> <rxieK-5nU-15@gated-at.bofh.it> <rxieK-5nU-13@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Tue, May 10, 2016 at 07:00:23PM +0300, Andy Shevchenko wrote: > On Tue, 2016-05-10 at 21:29 +0530, Vinod Koul wrote: > > On Wed, May 04, 2016 at 10:29:40PM +0300, Andy Shevchenko wrote: > > > > > > Rename cmd_pause to cmd_suspend to be clear that latter capability > > > reflects > > > pause AND resume. > > How does cmd_suspend be any clearer to reflect that channel is paused > > and > > not. One can argue this might be related to power management suspend > > Okay, I'm open to suggestions. My main point that name should not > represent only pause or resume, rather both. I am actually okay with this name, but while getting the capablities, we should rather tell user if both are supported or not. Perhaps make it a bit mask? -- ~Vinod
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v1 2/2] dmaengine: rename cmd_pause to cmd_suspend Andy Shevchenko <andriy.shevchenko@linux.intel.com> - 2016-05-04 21:40 +0200
Re: [PATCH v1 2/2] dmaengine: rename cmd_pause to cmd_suspend Andy Shevchenko <andriy.shevchenko@linux.intel.com> - 2016-05-10 18:00 +0200
Re: [PATCH v1 2/2] dmaengine: rename cmd_pause to cmd_suspend Vinod Koul <vinod.koul@intel.com> - 2016-05-10 18:10 +0200
Re: [PATCH v1 2/2] dmaengine: rename cmd_pause to cmd_suspend Vinod Koul <vinod.koul@intel.com> - 2016-05-10 18:00 +0200
csiph-web