Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1399771
| From | Mathieu OTHACEHE <m.othacehe@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 00/36] usb: serial: ti_usb_3410_5052: clean driver |
| Date | 2016-05-12 11:00 +0200 |
| Message-ID | <rxUDo-21y-3@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
Hi,
The now reverted mxu11x0 turned out to be a copy of ti_usb_3410_5052 driver.
This aim of this serie is to apply all of the cleanups we did in mxu11x0 to
ti_usb_3410_5052.
Thank you,
Mathieu
Mathieu OTHACEHE (36):
usb: serial: ti_usb_3410_5052: Remove useless comments
usb: serial: ti_usb_3410_5052: use __packed instead of
__attribute__((packed))
usb: serial: ti_usb_3410_5052: Remove ti_usb_3410_5052.h
usb: serial: ti_usb_3410_5052: Use inline functions rather than macro
usb: serial: ti_usb_3410_5052: Remove unused data structures
usb: serial: ti_usb_3410_5052: Do not use __uX types
usb: serial: ti_usb_3410_5052: Remove closing_wait module parameter
usb: serial: ti_usb_3410_5052: Remove useless dev_dbg messages
usb: serial: ti_usb_3410_5052: Use kzalloc instead of kmalloc
usb: serial: ti_usb_3410_5052: Remove useless NULL-testing
usb: serial: ti_usb_3410_5052: Use C_X macros instead of c_cflag
manipulation
usb: serial: ti_usb_3410_5052: Use generic read/write callbacks
usb: serial: ti_usb_3410_5052: Remove unused variables
usb: serial: ti_usb_3410_5052: Use macros instead of magic values
usb: serial: ti_usb_3410_5052: Remove in_sync and out_sync functions
usb: serial: ti_usb_3410_5052: Use bulk_out_size in TIOCGSERIAL
usb: serial: ti_usb_3410_5052: Remove useless tty_wakeup
usb: serial: ti_usb_3410_5052: Change ti_write_byte function arguments
usb: serial: ti_usb_3410_5052: Do not modify interrupt context
usb: serial: ti_usb_3410_5052: Remove usb_serial pointer in ti_port
usb: serial: ti_usb_3410_5052: Use generic close function
usb: serial: ti_usb_3410_5052: Change ti_get/set_serial_info function
arguments
usb: serial: ti_usb_3410_5052: Do not set shadow mcr in open callback
usb: serial: ti_usb_3410_5052: Use usb_serial_generic_open
usb: serial: ti_usb_3410_5052: Check old_termios parameter in
set_termios
usb: serial: ti_usb_3410_5052: Fix firmware downloading
usb: serial: ti_usb_3410_5052: Standardize debug and error messages
usb: serial: ti_usb_3410_5052: Use variables for vendor and product
usb: serial: ti_usb_3410_5052: Set shadow msr before waking up waiters
usb: serial: ti_usb_3410_5052: Remove backpointer in ti_port
usb: serial: ti_usb_3410_5052: Use a mutex to protect shadow mcr
usb: serial: ti_usb_3410_5052: Remove prefixes from private structures
usb: serial: ti_usb_3410_5052: Add CMSPAR support
usb: serial: ti_usb_3410_5052: Fix indentation problems
usb: serial: ti_usb_3410_5052: Remove function prototypes
usb: serial: ti_usb_3410_5052: Add myself as an author
drivers/usb/serial/ti_usb_3410_5052.c | 2055 +++++++++++++++------------------
drivers/usb/serial/ti_usb_3410_5052.h | 14 +-
2 files changed, 937 insertions(+), 1132 deletions(-)
--
2.8.2
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
[PATCH 00/36] usb: serial: ti_usb_3410_5052: clean driver Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-05-12 11:00 +0200
[PATCH 29/36] usb: serial: ti_usb_3410_5052: Set shadow msr before waking up waiters Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-05-12 11:00 +0200
[PATCH 17/36] usb: serial: ti_usb_3410_5052: Remove useless tty_wakeup Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-05-12 11:00 +0200
[PATCH 19/36] usb: serial: ti_usb_3410_5052: Do not modify interrupt context Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-05-12 11:00 +0200
[PATCH 15/36] usb: serial: ti_usb_3410_5052: Remove in_sync and out_sync functions Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-05-12 11:00 +0200
[PATCH 01/36] usb: serial: ti_usb_3410_5052: Remove useless comments Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-05-12 11:00 +0200
[PATCH 27/36] usb: serial: ti_usb_3410_5052: Standardize debug and error messages Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-05-12 11:00 +0200
[PATCH 26/36] usb: serial: ti_usb_3410_5052: Fix firmware downloading Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-05-12 11:00 +0200
[PATCH 24/36] usb: serial: ti_usb_3410_5052: Use usb_serial_generic_open Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-05-12 11:00 +0200
[PATCH 30/36] usb: serial: ti_usb_3410_5052: Remove backpointer in ti_port Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-05-12 11:00 +0200
[PATCH 31/36] usb: serial: ti_usb_3410_5052: Use a mutex to protect shadow mcr Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-05-12 11:00 +0200
[PATCH 23/36] usb: serial: ti_usb_3410_5052: Do not set shadow mcr in open callback Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-05-12 11:00 +0200
[PATCH 32/36] usb: serial: ti_usb_3410_5052: Remove prefixes from private structures Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-05-12 11:00 +0200
[PATCH 10/36] usb: serial: ti_usb_3410_5052: Remove useless NULL-testing Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-05-12 11:00 +0200
[PATCH 36/36] usb: serial: ti_usb_3410_5052: Add myself as an author Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-05-12 11:00 +0200
[PATCH 35/36] usb: serial: ti_usb_3410_5052: Remove function prototypes Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-05-12 11:00 +0200
[PATCH 22/36] usb: serial: ti_usb_3410_5052: Change ti_get/set_serial_info function arguments Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-05-12 11:00 +0200
[PATCH 33/36] usb: serial: ti_usb_3410_5052: Add CMSPAR support Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-05-12 11:00 +0200
[PATCH 25/36] usb: serial: ti_usb_3410_5052: Check old_termios parameter in set_termios Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-05-12 11:00 +0200
[PATCH 34/36] usb: serial: ti_usb_3410_5052: Fix indentation problems Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-05-12 11:00 +0200
[PATCH 06/36] usb: serial: ti_usb_3410_5052: Do not use __uX types Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-05-12 11:10 +0200
[PATCH 12/36] usb: serial: ti_usb_3410_5052: Use generic read/write callbacks Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-05-12 11:10 +0200
[PATCH 02/36] usb: serial: ti_usb_3410_5052: use __packed instead of __attribute__((packed)) Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-05-12 11:10 +0200
[PATCH 05/36] usb: serial: ti_usb_3410_5052: Remove unused data structures Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-05-12 11:10 +0200
[PATCH 08/36] usb: serial: ti_usb_3410_5052: Remove useless dev_dbg messages Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-05-12 11:10 +0200
[PATCH 16/36] usb: serial: ti_usb_3410_5052: Use bulk_out_size in TIOCGSERIAL Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-05-12 11:10 +0200
[PATCH 14/36] usb: serial: ti_usb_3410_5052: Use macros instead of magic values Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-05-12 11:10 +0200
[PATCH 07/36] usb: serial: ti_usb_3410_5052: Remove closing_wait module parameter Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-05-12 11:10 +0200
[PATCH 20/36] usb: serial: ti_usb_3410_5052: Remove usb_serial pointer in ti_port Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-05-12 11:10 +0200
[PATCH 04/36] usb: serial: ti_usb_3410_5052: Use inline functions rather than macro Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-05-12 11:10 +0200
Re: [PATCH 04/36] usb: serial: ti_usb_3410_5052: Use inline functions rather than macro Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> - 2016-05-12 14:10 +0200
[PATCH 13/36] usb: serial: ti_usb_3410_5052: Remove unused variables Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-05-12 11:10 +0200
[PATCH 18/36] usb: serial: ti_usb_3410_5052: Change ti_write_byte function arguments Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-05-12 11:10 +0200
[PATCH 11/36] usb: serial: ti_usb_3410_5052: Use C_X macros instead of c_cflag manipulation Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-05-12 11:10 +0200
[PATCH 03/36] usb: serial: ti_usb_3410_5052: Remove ti_usb_3410_5052.h Mathieu OTHACEHE <m.othacehe@gmail.com> - 2016-05-12 11:10 +0200
csiph-web