Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1399692

Re: [PATCH v6 00/13] x86/xsaves: Fix XSAVES issues

From Ingo Molnar <mingo@kernel.org>
Newsgroups linux.kernel
Subject Re: [PATCH v6 00/13] x86/xsaves: Fix XSAVES issues
Date 2016-05-12 08:50 +0200
Message-ID <rxSBz-im-15@gated-at.bofh.it> (permalink)
References <rxppT-4nc-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


* Yu-cheng Yu <yu-cheng.yu@intel.com> wrote:

> XSAVES is a kernel-mode instruction. It offers a compacted format and
> memory-write optimization. These patches fix issues in the first
> implementation.
> 
> Changes since Version 5:
> 
> Patch 1, 2 - Change names to fpu_user_xstate_size and fpu_kernel_xstate_size;
>              fix some comments, etc.
> 
> Patch 11 - In addition to a warning, make __raw_xsave_addr() return NULL
>            when a disabled xstate component address is requested.
> 
> Patch 12 - Add more details in the comments of why this patch is needed;
>            make a new macro for xcomp_bv[63].
> 
> Yu-cheng Yu (13):
>   x86/xsaves: Define and use fpu_user_xstate_size

So if you look at the git log of arch/x86/kernel/fpu/ then you'll see that the 
standard tag for FPU code is 'x86/fpu: ', for purely xstate related patch it's 
'x86/fpu/xstate: '.

>   x86/xsaves: Rename xstate_size to fpu_kernel_xstate_size to distinguish from fpu_user_xstate_size
>   x86/xsaves: Keep init_fpstate.xsave.header.xfeatures as zero for init optimization
>   x86/xsaves: Introduce a new check that allows correct xstates copy from kernel to user directly
>   x86/xsaves: Align xstate components according to CPUID
>   x86/xsaves: Supervisor state component offset

Please start all commit titles with verbs.

Also, this series is clearly too big. I was under the impression that the series 
was ready, but there's a number of small details that were pointed out (none of 
them very serious) - so how about you send a series of the first 4 patches next 
time around, and only send another 4 once those 4 first patches get applied to 
x86/fpu?

This makes it much easier to review, which reduces reviewer frustration; and it 
also allows you to focus more on incorporating feedback, without having to juggle 
13 patches all the time.

Ok?

Thanks,

	Ingo

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH v6 00/13] x86/xsaves: Fix XSAVES issues Yu-cheng Yu <yu-cheng.yu@intel.com> - 2016-05-11 01:40 +0200
  Re: [PATCH v6 00/13] x86/xsaves: Fix XSAVES issues Borislav Petkov <bp@suse.de> - 2016-05-11 06:20 +0200
    Re: [PATCH v6 00/13] x86/xsaves: Fix XSAVES issues Yu-cheng Yu <yu-cheng.yu@intel.com> - 2016-05-11 22:10 +0200
      Re: [PATCH v6 00/13] x86/xsaves: Fix XSAVES issues Borislav Petkov <bp@suse.de> - 2016-05-11 22:20 +0200
  Re: [PATCH v6 00/13] x86/xsaves: Fix XSAVES issues Ingo Molnar <mingo@kernel.org> - 2016-05-12 08:50 +0200

csiph-web