Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1390672
| From | Lu Baolu <baolu.lu@linux.intel.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v6 04/10] regulator: fixed: add support for ACPI interface |
| Date | 2016-04-29 02:40 +0200 |
| Message-ID | <rt4Do-52y-9@gated-at.bofh.it> (permalink) |
| References | (4 earlier) <rs8pI-5ZZ-9@gated-at.bofh.it> <rsmVI-1a3-3@gated-at.bofh.it> <rswV3-1g9-11@gated-at.bofh.it> <rsN9v-6ll-3@gated-at.bofh.it> <rsXLz-7xX-1@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Hi, On 04/29/2016 01:15 AM, Mark Brown wrote: > On Thu, Apr 28, 2016 at 01:55:35PM +0800, Lu Baolu wrote: > >> How about below code? >> + gpiod = gpiod_get(dev, "vbus_en", GPIOD_ASIS); >> + if (IS_ERR(gpiod)) >> + return PTR_ERR(gpiod); >> + >> + config->gpio = desc_to_gpio(gpiod); >> + config->enable_high = device_property_read_bool(dev, >> + "enable-active-high"); >> + gpiod_put(gpiod); > > That looks reasonable, though if you use "gpio" as the name like DT you > could keep the code the same which would be even better? Not super > crticial though. Systems might implement the name mapping in BIOS by implementing _DSD. The "gpio" looks a little generic. I'd like to use a function specific name. I will send a refreshed patch later. Best regards, Lu Baolu
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
Re: [PATCH v6 04/10] regulator: fixed: add support for ACPI interface Mark Brown <broonie@kernel.org> - 2016-04-28 19:20 +0200 Re: [PATCH v6 04/10] regulator: fixed: add support for ACPI interface Lu Baolu <baolu.lu@linux.intel.com> - 2016-04-29 02:40 +0200
csiph-web