Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1381358

Re: [PATCH] mm/memblock: move memblock_{add,reserve}_region into memblock_{add,reserve}

From Ard Biesheuvel <ard.biesheuvel@linaro.org>
Newsgroups linux.kernel
Subject Re: [PATCH] mm/memblock: move memblock_{add,reserve}_region into memblock_{add,reserve}
Date 2016-04-18 10:20 +0200
Message-ID <rpczw-2aB-17@gated-at.bofh.it> (permalink)
References <rp0oG-SM-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On 17 April 2016 at 21:14, Alexander Kuleshov <kuleshovmail@gmail.com> wrote:
> From: 0xAX <kuleshovmail@gmail.com>
>
> The memblock_add_region() and memblock_reserve_region do not nothing specific
> before the call of the memblock_add_range(), only print debug output.
>
> We can do the same in the memblock_add() and memblock_reserve() since both
> memblock_add_region() and memblock_reserve_region are not used by anybody
> outside of memblock.c and the memblock_{add,reserve}() have the same set of
> flags and nids.
>
> Since the memblock_add_region() and memblock_reserve_region() anyway will be
> inlined, there will not be functional changes, but will improve code readability
> a little.
>
> Signed-off-by: Alexander Kuleshov <kuleshovmail@gmail.com>

Acked-by: Ard Biesheuvel <ard.biesheuvel@linaro.org>

> ---
>  mm/memblock.c | 28 ++++++----------------------
>  1 file changed, 6 insertions(+), 22 deletions(-)
>
> diff --git a/mm/memblock.c b/mm/memblock.c
> index b570ddd..3b93daa 100644
> --- a/mm/memblock.c
> +++ b/mm/memblock.c
> @@ -606,22 +606,14 @@ int __init_memblock memblock_add_node(phys_addr_t base, phys_addr_t size,
>         return memblock_add_range(&memblock.memory, base, size, nid, 0);
>  }
>
> -static int __init_memblock memblock_add_region(phys_addr_t base,
> -                                               phys_addr_t size,
> -                                               int nid,
> -                                               unsigned long flags)
> +int __init_memblock memblock_add(phys_addr_t base, phys_addr_t size)
>  {
>         memblock_dbg("memblock_add: [%#016llx-%#016llx] flags %#02lx %pF\n",
>                      (unsigned long long)base,
>                      (unsigned long long)base + size - 1,
> -                    flags, (void *)_RET_IP_);
> -
> -       return memblock_add_range(&memblock.memory, base, size, nid, flags);
> -}
> +                    0UL, (void *)_RET_IP_);
>
> -int __init_memblock memblock_add(phys_addr_t base, phys_addr_t size)
> -{
> -       return memblock_add_region(base, size, MAX_NUMNODES, 0);
> +       return memblock_add_range(&memblock.memory, base, size, MAX_NUMNODES, 0);
>  }
>
>  /**
> @@ -732,22 +724,14 @@ int __init_memblock memblock_free(phys_addr_t base, phys_addr_t size)
>         return memblock_remove_range(&memblock.reserved, base, size);
>  }
>
> -static int __init_memblock memblock_reserve_region(phys_addr_t base,
> -                                                  phys_addr_t size,
> -                                                  int nid,
> -                                                  unsigned long flags)
> +int __init_memblock memblock_reserve(phys_addr_t base, phys_addr_t size)
>  {
>         memblock_dbg("memblock_reserve: [%#016llx-%#016llx] flags %#02lx %pF\n",
>                      (unsigned long long)base,
>                      (unsigned long long)base + size - 1,
> -                    flags, (void *)_RET_IP_);
> -
> -       return memblock_add_range(&memblock.reserved, base, size, nid, flags);
> -}
> +                    0UL, (void *)_RET_IP_);
>
> -int __init_memblock memblock_reserve(phys_addr_t base, phys_addr_t size)
> -{
> -       return memblock_reserve_region(base, size, MAX_NUMNODES, 0);
> +       return memblock_add_range(&memblock.reserved, base, size, MAX_NUMNODES, 0);
>  }
>
>  /**
> --
> 2.8.0.rc3.212.g1f992f2.dirty
>

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH] mm/memblock: move memblock_{add,reserve}_region into memblock_{add,reserve} Alexander Kuleshov <kuleshovmail@gmail.com> - 2016-04-17 21:20 +0200
  Re: [PATCH] mm/memblock: move memblock_{add,reserve}_region into memblock_{add,reserve} Ard Biesheuvel <ard.biesheuvel@linaro.org> - 2016-04-18 10:20 +0200

csiph-web