Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1382418
| From | Borislav Petkov <bp@alien8.de> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [tip:x86/asm] x86/entry: Rename is_{ia32,x32}_task() to in_{ia32,x32}_syscall() |
| Date | 2016-04-19 13:40 +0200 |
| Message-ID | <rpCaD-6a2-29@gated-at.bofh.it> (permalink) |
| References | <rphIT-6ug-33@gated-at.bofh.it> <rpAiw-4BY-37@gated-at.bofh.it> <rpBRg-615-1@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Tue, Apr 19, 2016 at 01:15:30PM +0200, Ingo Molnar wrote:
> So I'd suggest the following renames to harmonize these concepts:
>
> - CONFIG_IA32_EMULATION => CONFIG_X86_32_ABI
> this lines up nicely with: CONFIG_X86_X32_ABI
Except that the only difference now is the "X" in the strings. So one
would need more coffee when staring at those. :)
>
> - is_ia32_syscall() -> is_x86_32_syscall()
> - is_x32_syscall() -> is_x86_x32_syscall()
>
> - is_compat_syscall() remains as-is.
>
> ... thoughts?
Still, getting those names streamlined and logical is a step in the
right direction IMO.
--
Regards/Gruss,
Boris.
ECO tip #101: Trim your mails when you reply. Srsly.
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCHv5 1/3] x86: rename is_{ia32,x32}_task to in_{ia32,x32}_syscall Dmitry Safonov <dsafonov@virtuozzo.com> - 2016-04-18 15:50 +0200
[PATCHv5 3/3] selftest/x86: add mremap vdso 32-bit test Dmitry Safonov <dsafonov@virtuozzo.com> - 2016-04-18 15:50 +0200
Re: [PATCHv5 3/3] selftest/x86: add mremap vdso 32-bit test Andy Lutomirski <luto@amacapital.net> - 2016-04-21 22:10 +0200
[tip:x86/asm] x86/entry: Rename is_{ia32,x32}_task() to in_{ia32,x32}_syscall() tip-bot for Dmitry Safonov <tipbot@zytor.com> - 2016-04-19 11:40 +0200
Re: [tip:x86/asm] x86/entry: Rename is_{ia32,x32}_task() to in_{ia32,x32}_syscall() Ingo Molnar <mingo@kernel.org> - 2016-04-19 13:20 +0200
Re: [tip:x86/asm] x86/entry: Rename is_{ia32,x32}_task() to in_{ia32,x32}_syscall() Borislav Petkov <bp@alien8.de> - 2016-04-19 13:40 +0200
Re: [tip:x86/asm] x86/entry: Rename is_{ia32,x32}_task() to in_{ia32,x32}_syscall() "H. Peter Anvin" <hpa@zytor.com> - 2016-04-19 19:10 +0200
Re: [tip:x86/asm] x86/entry: Rename is_{ia32,x32}_task() to in_{ia32,x32}_syscall() Andy Lutomirski <luto@amacapital.net> - 2016-04-19 18:10 +0200
Re: [tip:x86/asm] x86/entry: Rename is_{ia32,x32}_task() to in_{ia32,x32}_syscall() Ingo Molnar <mingo@kernel.org> - 2016-04-22 10:40 +0200
csiph-web