Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1380156
| From | mchristi@redhat.com |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 36/42] ide cd: do not set REQ_WRITE on requests. |
| Date | 2016-04-15 21:20 +0200 |
| Message-ID | <rohrB-81o-49@gated-at.bofh.it> (permalink) |
| References | <rohrA-81o-9@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
From: Mike Christie <mchristi@redhat.com> The block layer will set the correct READ/WRITE operation flags/fields when creating a request, so there is not need for drivers to set the REQ_WRITE flag. Signed-off-by: Mike Christie <mchristi@redhat.com> Reviewed-by: Christoph Hellwig <hch@lst.de> Reviewed-by: Hannes Reinecke <hare@suse.com> --- drivers/ide/ide-cd_ioctl.c | 3 --- 1 file changed, 3 deletions(-) diff --git a/drivers/ide/ide-cd_ioctl.c b/drivers/ide/ide-cd_ioctl.c index 474173e..5887a7a 100644 --- a/drivers/ide/ide-cd_ioctl.c +++ b/drivers/ide/ide-cd_ioctl.c @@ -459,9 +459,6 @@ int ide_cdrom_packet(struct cdrom_device_info *cdi, layer. the packet must be complete, as we do not touch it at all. */ - if (cgc->data_direction == CGC_DATA_WRITE) - flags |= REQ_WRITE; - if (cgc->sense) memset(cgc->sense, 0, sizeof(struct request_sense)); -- 2.7.2
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 00/42] v7: separate operations from flags in the bio/request structs mchristi@redhat.com - 2016-04-15 21:20 +0200
[PATCH 31/42] block: convert merge/insert code to check for REQ_OPs. mchristi@redhat.com - 2016-04-15 21:20 +0200
[PATCH 38/42] block, fs: remove old REQ definitions. mchristi@redhat.com - 2016-04-15 21:20 +0200
[PATCH 42/42] block, drivers, fs: rename REQ_FLUSH to REQ_PREFLUSH mchristi@redhat.com - 2016-04-15 21:20 +0200
[PATCH 40/42] block, drivers: add REQ_OP_FLUSH operation mchristi@redhat.com - 2016-04-15 21:20 +0200
[PATCH 25/42] target: set bi_op to REQ_OP mchristi@redhat.com - 2016-04-15 21:20 +0200
[PATCH 09/42] btrfs: update __btrfs_map_block for bi_op transition mchristi@redhat.com - 2016-04-15 21:20 +0200
[PATCH 29/42] block: prepare elevator to use REQ_OPs. mchristi@redhat.com - 2016-04-15 21:20 +0200
[PATCH 11/42] f2fs: set bi_op to REQ_OP mchristi@redhat.com - 2016-04-15 21:20 +0200
[PATCH 22/42] drbd: set bi_op to REQ_OP mchristi@redhat.com - 2016-04-15 21:20 +0200
[PATCH 36/42] ide cd: do not set REQ_WRITE on requests. mchristi@redhat.com - 2016-04-15 21:20 +0200
[PATCH 34/42] drivers: set request op to REQ_OP mchristi@redhat.com - 2016-04-15 21:20 +0200
[PATCH 33/42] block: convert rq_data_dir helper to use REQ_OPs mchristi@redhat.com - 2016-04-15 21:30 +0200
[PATCH 32/42] block: convert is_sync helpers to use REQ_OPs. mchristi@redhat.com - 2016-04-15 21:30 +0200
[PATCH 30/42] blkg_rwstat: separate op from flags mchristi@redhat.com - 2016-04-15 21:30 +0200
[PATCH 21/42] bcache: set bi_op to REQ_OP mchristi@redhat.com - 2016-04-15 21:30 +0200
[PATCH 27/42] block: prepare request creation/destruction code to use REQ_OPs mchristi@redhat.com - 2016-04-15 21:30 +0200
[PATCH 23/42] md/raid: set bi_op to REQ_OP mchristi@redhat.com - 2016-04-15 21:30 +0200
[PATCH] RAID Cleanup for bio-split Shaun Tancheff <shaun@tancheff.com> - 2016-04-24 01:20 +0200
[PATCH 39/42] block: shrink bio/request fields mchristi@redhat.com - 2016-04-15 21:30 +0200
[PATCH 37/42] block, fs, drivers: do use bi_rw/cmd_flags for REQ_OPs. mchristi@redhat.com - 2016-04-15 21:30 +0200
[PATCH 28/42] block: prepare mq request creation to use REQ_OPs mchristi@redhat.com - 2016-04-15 21:30 +0200
[PATCH 24/42] xen: set bi_op to REQ_OP mchristi@redhat.com - 2016-04-15 21:30 +0200
[PATCH 26/42] block: copy bio op to request op mchristi@redhat.com - 2016-04-15 21:30 +0200
[PATCH 35/42] blktrace: get op from req->op/bio->bi_op mchristi@redhat.com - 2016-04-15 21:30 +0200
[PATCH 16/42] nilfs: set bi_op to REQ_OP mchristi@redhat.com - 2016-04-15 21:40 +0200
Re: [PATCH 16/42] nilfs: set bi_op to REQ_OP Ryusuke Konishi <konishi.ryusuke@lab.ntt.co.jp> - 2016-04-18 18:10 +0200
[PATCH 13/42] xfs: set bi_op to REQ_OP mchristi@redhat.com - 2016-04-15 21:40 +0200
[PATCH 10/42] btrfs: use bio fields for op and flags mchristi@redhat.com - 2016-04-15 21:40 +0200
[PATCH 20/42] dm: pass dm stats data dir instead of bi_rw mchristi@redhat.com - 2016-04-15 21:40 +0200
[PATCH 07/42] btrfs: have submit_one_bio users setup bio bi_op mchristi@redhat.com - 2016-04-15 21:40 +0200
[PATCH 04/42] fs: have submit_bh users pass in op and flags separately mchristi@redhat.com - 2016-04-15 21:40 +0200
[PATCH 12/42] gfs2: set bi_op to REQ_OP mchristi@redhat.com - 2016-04-15 21:40 +0200
[PATCH 05/42] fs: have ll_rw_block users pass in op and flags separately mchristi@redhat.com - 2016-04-15 21:40 +0200
[PATCH 14/42] hfsplus: set bi_op to REQ_OP mchristi@redhat.com - 2016-04-15 21:40 +0200
[PATCH 08/42] btrfs: set bi_op tp REQ_OP mchristi@redhat.com - 2016-04-15 21:40 +0200
[PATCH 06/42] direct-io: set bi_op to REQ_OP mchristi@redhat.com - 2016-04-15 21:40 +0200
[PATCH 18/42] pm: set bi_op to REQ_OP mchristi@redhat.com - 2016-04-15 21:40 +0200
[PATCH 15/42] mpage: set bi_op to REQ_OP mchristi@redhat.com - 2016-04-15 21:40 +0200
[PATCH 17/42] ocfs2: set bi_op to REQ_OP mchristi@redhat.com - 2016-04-15 21:40 +0200
[PATCH 03/42] block, fs, mm, drivers: set bi_op to REQ_OP mchristi@redhat.com - 2016-04-15 21:50 +0200
Re: [PATCH 00/42] v7: separate operations from flags in the bio/request structs Mike Snitzer <snitzer@redhat.com> - 2016-04-15 21:50 +0200
csiph-web