Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1379909
| From | Will Deacon <will.deacon@arm.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v2 04/17] arm64: Introduce pmd_thp_or_huge |
| Date | 2016-04-15 17:20 +0200 |
| Message-ID | <rodHj-535-13@gated-at.bofh.it> (permalink) |
| References | <rnPvk-2fL-5@gated-at.bofh.it> <rnPvm-2fL-49@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Thu, Apr 14, 2016 at 02:20:52PM +0100, Suzuki K Poulose wrote: > Add a helper to determine if a given pmd represents a huge page > either by hugetlb or thp, as we have for arm. This will be used > by KVM MMU code. > > Suggested-by: Mark Rutland <mark.rutland@arm.com> > Cc: Catalin Marinas <catalin.marinas@arm.com> > Cc: Steve Capper <steve.capper@linaro.org> > Cc: Will Deacon <will.deacon@arm.com> > Acked-by: Christoffer Dall <christoffer.dall@linaro.org> > Signed-off-by: Suzuki K Poulose <suzuki.poulose@arm.com> > --- > arch/arm64/include/asm/pgtable.h | 2 ++ > 1 file changed, 2 insertions(+) > > diff --git a/arch/arm64/include/asm/pgtable.h b/arch/arm64/include/asm/pgtable.h > index 989fef1..dda4aa9 100644 > --- a/arch/arm64/include/asm/pgtable.h > +++ b/arch/arm64/include/asm/pgtable.h > @@ -290,6 +290,8 @@ static inline pgprot_t mk_sect_prot(pgprot_t prot) > #define pmd_mkyoung(pmd) pte_pmd(pte_mkyoung(pmd_pte(pmd))) > #define pmd_mknotpresent(pmd) (__pmd(pmd_val(pmd) & ~PMD_TYPE_MASK)) > > +#define pmd_thp_or_huge(pmd) (pmd_huge(pmd) || pmd_trans_huge(pmd)) Acked-by: Will Deacon <will.deacon@arm.com> Will
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH v2 04/17] arm64: Introduce pmd_thp_or_huge Suzuki K Poulose <suzuki.poulose@arm.com> - 2016-04-14 15:30 +0200 Re: [PATCH v2 04/17] arm64: Introduce pmd_thp_or_huge Will Deacon <will.deacon@arm.com> - 2016-04-15 17:20 +0200
csiph-web