Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1377758

Re: [PATCH] perf/x86/intel/pt: Don't die on VMXON

From Ingo Molnar <mingo@kernel.org>
Newsgroups linux.kernel
Subject Re: [PATCH] perf/x86/intel/pt: Don't die on VMXON
Date 2016-04-13 13:00 +0200
Message-ID <rnqGC-8ro-15@gated-at.bofh.it> (permalink)
References (2 earlier) <rkTF7-2Y2-1@gated-at.bofh.it> <rkUhQ-3fx-3@gated-at.bofh.it> <rkWjD-52m-13@gated-at.bofh.it> <rnpKy-7Mh-9@gated-at.bofh.it> <rnqng-8j6-27@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


* Alexander Shishkin <alexander.shishkin@linux.intel.com> wrote:

> Ingo Molnar <mingo@kernel.org> writes:
> 
> >> @@ -3144,6 +3146,8 @@ static void vmclear_local_loaded_vmcss(void)
> >>  static void kvm_cpu_vmxoff(void)
> >>  {
> >>  	asm volatile (__ex(ASM_VMX_VMXOFF) : : : "cc");
> >> +
> >> +	intel_pt_vmx(0);
> >>  }
> >
> > Yeah so the name intel_pt_vmx() is pretty information-free because it has no verb, 
> > only nouns - please name new functions descriptively to after what they do!
> 
> I do agree that it can use a better name (and this is a second attempt
> already).
> 
> > Something like intel_pt_set_vmx_state() or so?
> 
> Hmm how about intel_pt_handle_vmx()? Ideally, akin to the VMXON/VMXOFF insns, 
> this could be two functions (intel_pt_handle_vmx{on,off}()) if the global 
> namespace can take it.

Sure, intel_pt_handle_vmx(0/1) sounds good too. I wouldn't split it into two 
functions ...

Thanks,

	Ingo

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

Re: [PATCH] perf/x86/intel/pt: Don't die on VMXON Peter Zijlstra <peterz@infradead.org> - 2016-04-06 11:00 +0200
  Re: [PATCH] perf/x86/intel/pt: Don't die on VMXON Alexander Shishkin <alexander.shishkin@linux.intel.com> - 2016-04-06 13:20 +0200
    Re: [PATCH] perf/x86/intel/pt: Don't die on VMXON Peter Zijlstra <peterz@infradead.org> - 2016-04-06 14:00 +0200
      Re: [PATCH] perf/x86/intel/pt: Don't die on VMXON Borislav Petkov <bp@alien8.de> - 2016-04-06 14:00 +0200
        Re: [PATCH] perf/x86/intel/pt: Don't die on VMXON Alexander Shishkin <alexander.shishkin@linux.intel.com> - 2016-04-06 14:20 +0200
      Re: [PATCH] perf/x86/intel/pt: Don't die on VMXON Alexander Shishkin <alexander.shishkin@linux.intel.com> - 2016-04-06 16:10 +0200
        Re: [PATCH] perf/x86/intel/pt: Don't die on VMXON Ingo Molnar <mingo@kernel.org> - 2016-04-13 12:00 +0200
          Re: [PATCH] perf/x86/intel/pt: Don't die on VMXON Alexander Shishkin <alexander.shishkin@linux.intel.com> - 2016-04-13 12:40 +0200
            Re: [PATCH] perf/x86/intel/pt: Don't die on VMXON Ingo Molnar <mingo@kernel.org> - 2016-04-13 13:00 +0200
              Re: [PATCH] perf/x86/intel/pt: Don't die on VMXON Alexander Shishkin <alexander.shishkin@linux.intel.com> - 2016-04-13 15:50 +0200

csiph-web