Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1377405

Re: [PATCH] of: Add generic handling for hardware incomplete fail state

From Tom Rini <trini@konsulko.com>
Newsgroups linux.kernel
Subject Re: [PATCH] of: Add generic handling for hardware incomplete fail state
Date 2016-04-13 01:30 +0200
Message-ID <rnfUS-7Bu-9@gated-at.bofh.it> (permalink)
References <rnboe-3xO-3@gated-at.bofh.it> <rncWZ-4S9-5@gated-at.bofh.it> <rnf8u-6Qp-17@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


[Multipart message — attachments visible in raw view] - view raw

On Tue, Apr 12, 2016 at 03:39:30PM -0700, Frank Rowand wrote:
> On 4/12/2016 1:13 PM, Frank Rowand wrote:
> > Hi Tony,
> 
> < snip >
> 
> > With that change, the bulk of your patch looks good, with
> > minor changes:
> > 
> >   __of_device_is_available() would not need to change.
> > 
> >   __of_device_is_incomplete() would change to check the new
> >   boolean property.  (And I would suggest renaming it to
> >   something that conveys it is ok to power manage the
> >   device, but do not do anything else to the device.)
> > 
> > -Frank
> 
> One more thought...
> 
> Are there multiple drivers that need to follow this
> pattern, or just one at the moment?  If just one driver,
> then I would suggest open-coding accessing the property
> in the probe routine instead of adding the helper
> functions.  If more drivers appear with the same
> pattern then the helper functions could be added.

This is a many problem.  I was trying to describe this at the BoF but
it's something more along the lines of:

SoC family ABxx supports 20 IP blocks which will always be present on
the physical chip but depending on the exact 'xx' many of those 20
blocks will be powered but 100% unusable.  Based on the 'xx' we will
know this, and know that we must turn them off.

I'm under the impression that it's not just "turn them off for power
saving" but "turn them off so they don't break PM".

-- 
Tom

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH] of: Add generic handling for hardware incomplete fail state Tony Lindgren <tony@atomide.com> - 2016-04-12 20:40 +0200
  Re: [PATCH] of: Add generic handling for hardware incomplete fail  state Frank Rowand <frowand.list@gmail.com> - 2016-04-12 22:20 +0200
    Re: [PATCH] of: Add generic handling for hardware incomplete fail  state Tony Lindgren <tony@atomide.com> - 2016-04-12 22:40 +0200
      Re: [PATCH] of: Add generic handling for hardware incomplete fail  state Frank Rowand <frowand.list@gmail.com> - 2016-04-12 23:50 +0200
        Re: [PATCH] of: Add generic handling for hardware incomplete fail  state Tony Lindgren <tony@atomide.com> - 2016-04-13 00:10 +0200
        Re: [PATCH] of: Add generic handling for hardware incomplete fail state Rob Herring <robh+dt@kernel.org> - 2016-04-13 00:30 +0200
          Re: [PATCH] of: Add generic handling for hardware incomplete fail  state Tony Lindgren <tony@atomide.com> - 2016-04-13 00:30 +0200
            Re: [PATCH] of: Add generic handling for hardware incomplete fail  state Tom Rini <trini@konsulko.com> - 2016-04-13 02:20 +0200
          Re: [PATCH] of: Add generic handling for hardware incomplete fail  state Frank Rowand <frowand.list@gmail.com> - 2016-04-13 00:40 +0200
    Re: [PATCH] of: Add generic handling for hardware incomplete fail  state Frank Rowand <frowand.list@gmail.com> - 2016-04-13 00:40 +0200
      Re: [PATCH] of: Add generic handling for hardware incomplete fail  state Tony Lindgren <tony@atomide.com> - 2016-04-13 01:20 +0200
      Re: [PATCH] of: Add generic handling for hardware incomplete fail  state Tom Rini <trini@konsulko.com> - 2016-04-13 01:30 +0200

csiph-web