Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1379120

Re: [PATCH V2 01/15] coresight: tmc: modifying naming convention

From Suzuki K Poulose <Suzuki.Poulose@arm.com>
Newsgroups linux.kernel
Subject Re: [PATCH V2 01/15] coresight: tmc: modifying naming convention
Date 2016-04-14 19:10 +0200
Message-ID <rnSWe-5pD-25@gated-at.bofh.it> (permalink)
References <rnaLv-2Vr-3@gated-at.bofh.it> <rnaLw-2Vr-13@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On 12/04/16 18:54, Mathieu Poirier wrote:
> According to the TMC architectural state machine, the 'stopped'
> state is reached when bit 2 (TMCReady) of the TMC Status register
> turns to '1'.  The code is correct but the naming convention isn't.
>
> The 'Triggered' bit occupies position '1' of the TMC Status register
> and has nothing to do with the indication of the TMC entering the
> stopped state. As such renaming function "tmc_wait_for_triggered()"
> and changing the #define to reflect what the code is really doing.
>
> This patch has no effect other than clarifying the semantic.
>
> Signed-off-by: Mathieu Poirier <mathieu.poirier@linaro.org>

Reviewed-by: Suzuki K Poulose <suzuki.poulose@arm.com>

Suzuki

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH V2 01/15] coresight: tmc: modifying naming convention Mathieu Poirier <mathieu.poirier@linaro.org> - 2016-04-12 20:00 +0200
  Re: [PATCH V2 01/15] coresight: tmc: modifying naming convention Suzuki K Poulose <Suzuki.Poulose@arm.com> - 2016-04-14 19:10 +0200

csiph-web